General discussion

Locked

Disable type ahead in "Run" start menu

By bad_dog ·
I am using Windows XP professional on my home computer. When I click "Start" then click on "Run" a dialogbox opens. When I start to type in the input area it automatically provides choices.
for example if I type "H"
a list appears like this:
http://techrepublic.com.com/2001-1-0.html
http://www.msn.com
http://amch.questionmarket.com

I want to hide the choices or delete them. In Windows 2000 professional this can be taken care of in the taskbar properties dialog box by simply clicking on the "Clear" button on the advanced tab. Doing this in XP Professional just deletes the My Documents history.

Thanks

This conversation is currently closed to new comments.

24 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by statykserver In reply to Disable type ahead in "R ...

Give this a try. Right click Internet explorer and delete all the offline temporary files, cookies and history. Now when you click on run and type h you won't see anything at all.

wierd but true

Collapse -

by statykserver In reply to

Right click internet explorer "internet options" and then delete all the temp files

Collapse -

by bad_dog In reply to

I already tried this. It doesn't work. I know I can clear the histroy by clicking on the tools/internet options and deleting history and this will clear the list. But I don't want to get rid of the history.

Collapse -

by razz2 In reply to Disable type ahead in "R ...

Those are in the following registry key:

HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersi
on\Explorer\RunMRU

There is no key that disables them that I know of (there is for
recent docs), but you could manually empty them and then
export the empty key. To clear them just double click the export
to reload it empty.

Collapse -

by bad_dog In reply to

ok I went to the registry key and all I saw was a
Name Type Data
(default) REG_SZ (value not set)

I right clicked on RunMRU and exported it. When I tried to delete (default) I got a message that said "Unable to delete all specified values"
When I went back to the dialog box and typed in "H" everything was still there.
I've never used the registry editor before so maybe I didn't get it right

Any other suggestions?

Collapse -

by ReWrite In reply to Disable type ahead in "R ...

There are some 3rd party apps to manage this or you can get tweakui. On the Paranoid tab you have the option to clear many of the mru lists on each logon.

Other than this you can manually delete the list by editing the registry by going to the following key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

and deleting all the entries.

Cheers.

RW

Collapse -

by bad_dog In reply to

see answer above. I'd rather not use a third party app if I don't have to Any other suggestions?

Collapse -

by EdLockett In reply to Disable type ahead in "R ...

Get Tweak UI.

Tweak UI is available for download from the microsoft site.

It will allow you to clear your run history.

But to be quite honest I can't see how this is a problem. Why do you choose start>run and then type 'h' anyway?

Collapse -

by bad_dog In reply to

Above answer already suggested downloading Tweak UI.

Collapse -

by dkzgambo In reply to Disable type ahead in "R ...

why dont u just clear ur history and start afresh?

Back to Windows Forum
24 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums