Question

Locked

Disabling the welcome screen and password in Windows XP

By gmwolfie ·
I don't know what happened, but suddenly when I perform a restart on my Windows XP Home machine, I have to click my name to complete the reboot. Prior to recently, the system simply rebooted and that was that. I never had to screw around with this clicking identity business. Is there, there must be, a way to totally disable this? I've been in the Control Panel/User Account area and there is little help there, I can stop the welcome screen, but still have to endure the password box that appears. There is no password setup, so it's simply a click. I've also noticed that another"user", namely, "ASP.NET Machine A..." also shows up here, any idea what this might be?

Any help here is appreciated.
Thanks,

Gerry

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

registry

by operator1 In reply to Disabling the welcome scr ...

hi,i cant tell what happened but you could go to registry and try from there.note that registry is tricky and be carefull inside.
change ONLY value below
key is
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ WindowsNT\CurrentVersion\Winlogon" and value is "AutoAdminLogon"
i hope you've done something in registry b4 but in case you didnt go to start ->run and type "regedit".Window like explorer will open and will show MyComputer icon with some HKEY like folders.now follow EXACTLY path from above until you reach WINLOGON key.Then on the right pane search for "AutoAdminLogon" value.it should be 0 and you should change it to 1.
BE CAREFULL NOT TO CHANGE SOMETHING ELSE OR YOU MIGHT NOT BOOT AT ALL.
Now restart and dont bother with the passwords.BUT...
this way you open your system to anyone phisically,from the network,in all ways.
so at least when you surf you should use user NOT admin account.make new user account with limited access(AND STRONG PASSWORD) for surfing. bye

Collapse -

If you do not want to edit registry directly,

by huoml In reply to registry

another way to do this is : download 'tweak UI' from MS site. This tool allows configuration of basic windows behaviour via GUI.

One of the option is Logon (on left side), expand Logon (by clicking on +) then select Autologon. Then on right side, you would see the option to 'logon automatically'. Apply and then exit. The next time you reboot, it should logon automatically, the way it used be.

hth

-H

Collapse -

Doesn't Work 100%

by TheGooch1 In reply to If you do not want to edi ...

I used tweakUI, and when the computer boots up, it still pops up the company legal notice, then you click "ok" and it then logs in automatically. So, it is almost fully automated, except for the click "ok" part. Is there a way to fix that?

-JohnG

Collapse -

try this...

by boxfiddler Moderator In reply to Disabling the welcome scr ...

Administrative Tools\Local Security Settings\
Look for Interactive Logon: Do not display last user name - enable this.

"The aspnet_wp or ASP.NET Machine Account is created when the Microsoft .Net Framework 1.1 is installed onto a Windows XP computer. The user is created to run the asp.net worker process used in Microsoft's Internet Information Services, which allows ASP.net to run on your local web server (This is pretty much its only use, it is not used to run normal .net managed executables). There is not a need to worry about this user's presence; it was not created in malicious way." (http://www.mvps.org/marksxp/WindowsXP/aspdot.php)

The above instructions are for WinXP Pro, but I believe that XP Home is similar. Been awhile since I fiddled in XP Home however.

Back to Web Development Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums