General discussion

Locked

Disabling Win2000Pro Desktop Properties

By syberdeath ·
How can I disable access to desktop properties in Windows 2000 Professional?
I looked for a way to edit the registry but I cant find one for Windows 2000. Thanks.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Disabling Win2000Pro Desktop Properties

by Parbo In reply to Disabling Win2000Pro Desk ...

what in particular are you looking for?
I might be able to help

Collapse -

Disabling Win2000Pro Desktop Properties

by syberdeath In reply to Disabling Win2000Pro Desk ...

Poster rated this answer

Collapse -

Disabling Win2000Pro Desktop Properties

by strakovsky In reply to Disabling Win2000Pro Desk ...

I have a little brutal solution. :) Login as an administrator, rename the file \\winnt\system32\desk.cpl to display.cpl, so if you right click a mouse on a desktop and select property, it shouldn't run anymore from there. Unfortunately the applet would still appear on the control panel. If you hide control panel from the start menu (you know of course how to do it), you can completely disable access to that feature. If you still need an access for non-administrative personnel to control panel (except the desktop property), I would recommend you to change desk.cpl file's extension during logon script execution. So no one except yourself is going to see that applet anywhere :) Basically this is it.

AFAIK, by changing the registry you could only show/hide pre-registered applets in CP, and I don't know the easiest way to disable desktop property menu-item then to hack the resource file.

Collapse -

Disabling Win2000Pro Desktop Properties

by syberdeath In reply to Disabling Win2000Pro Desk ...

yeah that is pretty brutal

Collapse -

Disabling Win2000Pro Desktop Properties

by kenalmoore In reply to Disabling Win2000Pro Desk ...

It took me awhile to find this one.
To Keep people from getting to the display applet in the control panel:
HKCU\Software\Microsoft\Windows\Currentversion\Polices\System
Look for NoDispCPL change setting to #1.

Collapse -

Disabling Win2000Pro Desktop Properties

by syberdeath In reply to Disabling Win2000Pro Desk ...

Thanks a lot! Where did you find it? E-mail me at syber@charter.net

Collapse -

Disabling Win2000Pro Desktop Properties

by syberdeath In reply to Disabling Win2000Pro Desk ...

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums