Question

Locked

Disk drive not appearing in my computer folder

By kole9292 ·
The disk drive (D:) isnt appearing in my computer folder. and when i go to properties it shows error code 39. it says its corrupted or missing. any help? i 've already tried reinstalling it

(windows xp home edition)

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

More information would be helpful

by nepenthe0 In reply to Disk drive not appearing ...

What is drive D? Is it a 2nd internal hard drive, an external USB-connected hard drive, an optical drive?

What does the Device Manager have to say about the drive?

Control Panel > Administrative Tools > Computer Management > Device Manager

Please post back, and we'll get you the information you need to fix the glitch.

The Device Manager error code 39 (XP Pro):

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing.

http://support.microsoft.com/default.aspx/kb/310123

Microsoft recommends uninstalling, then reinstalling the driver. If D is the optical drive, I see that True Blue has joined the thread and has given you the URL for the Microsoft bulletin on this issue.

Rick/Portland, OR

Collapse -

Check this link

by Jacky Howe In reply to Disk drive not appearing ...

http://support.microsoft.com/default.aspx/kb/314060

< add a bit >

First thing is to check to see if it is being picked up in the BIOS. If it is not there check your Cables. Try another Cable. If BIOS cant detect it then replace it. If it is there try the steps below.

Common BIOS entry Keys
F1
F2
DEL
ESC
F10
A user will know when to press this key when they see a message similar to the below example as the computer is booting. Some older computers may also display a flashing block to indicate when to press the F1 or F2 keys.

Press <F2> to enter BIOS setup

Tip: Hold a Key down, this will cause a stuck key error, which may allow you to enter the BIOS setup.

If the CD/DVD is not showing in Device Manager follow these directions for clearing the Upper/Lower Filters

Click on Start, Run and type in 'regedt32' and press Enter
Expand the "HKEY_LOCAL_MACHINE" key by clicking the "+" next to it.
Expand the "SYSTEM" Key
Expand the "CurrentControlSet" Key
Expand the "Control" Key
Expand the "Class" Key
Look for a key containing the following string of letter and numbers:{4D36E965-E325-11CE-BFC1-08002BE10318}
High light this key by left clicking on it
On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these Keys delete them by right clicking on them and choosing "delete" exit the registry.
Restart your PC.

Collapse -

resolved

by kole9292 In reply to Disk drive not appearing ...

yeah got it working now

Collapse -

Thats Great <NT>

by Jacky Howe In reply to resolved
Collapse -

re: resolved

by ThumbsUp2 In reply to resolved

It would be nice if you explained what you found and how you fixed it. That way, someone else with the same problem might be helped as well.

Besides that, if an answer given to you was helpful, it's customary to give them a thumbs up for their efforts. That's how we keep score around here!

Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Forums