General discussion

Locked

Disk Drive running in PIO

By Sprocket ·
I have a new Dell 4600 PC with 2 Hard drives (both new 80Gb and 120Gb) and a DVD+-RW.

I have the DVD+-RW on the second IDE cable and it runs happily in Ultra DMA mode 2. I have the 80Gb as my master drive on the first IDE cable and it runs happily in Ultra DMA mode 5.

If I add the 120Gb hard drive to either cable as a slave it runs in PIO mode (which ofcourse I don't want). But if I add it as a master on the second IDE cable it runs in Ultra DMA Mode 5, but the DVD+-RW will then only run in PIO mode on the slave.

How can I get all three to run in Ultra DMA mode?

I have tried deleting and reinstalling the IDE controllers.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Sprocket In reply to Disk Drive running in PIO

Its running Windows XP

Collapse -

by Sprocket In reply to Disk Drive running in PIO

Point value changed by question poster.

Collapse -

by Sprocket In reply to Disk Drive running in PIO

Point value changed by question poster.

Collapse -

by pierrejamme In reply to Disk Drive running in PIO

Russell Goulter had an identical post somewhere else are you he?
My 1st response would be to use Cable Select for everything as was one of the answers there, russell said it didn't work, amy for you.

Have you upgraded your BIOS with:
BIOS: Dell Dimension System BIOS, English, Dimension 4600, A09
Dated April 2, 2004?

This is what Dell has to say about PIO Mode:To resolve this problem, restore the system to PIO transfer mode.

Configure PIO Mode in Windows 2000

Click the Start button, point to Settings, and then click Control Panel.
The Control Panel window appears.
Double-click the System icon.
The System Properties window appears.
Click the Hardware tab, and then click the Device Manager button.
The Device Manager window appears.
Click the plus (+) sign next to IDE/ATAPI controllers.
Right-click Primary IDE Channel (or the channel the optical drive is installed on) and left-click Properties.
Click the Advanced Settings tab.
On the Transfer Mode pull-down menu, click to select PIO Mode Only.
Restart the computer.

Found at:
http://premiersupport.dell.com/us/en/kb/document.asp?nav=Knowledge_Base&DN=TT1076512&SvcTag=

Good Luck,
Peter

Collapse -

by Sprocket In reply to

Im not Russell Goulter, but Ill check his replies.

Its running the latest versions of Bios and contollers, and I have tried the above with no luck.

Collapse -

by Sprocket In reply to Disk Drive running in PIO

Point value changed by question poster.

Collapse -

by kennethsf In reply to Disk Drive running in PIO

Try this:

Enter to Dell system setup. (F2 when Dell logo is shown)

Probaby the second hard drive (slave) will be found as set to "off". Set it to Auto (it can be recognized by XP as an existant drive anyway, so it's better to check the drive settings manually, since not doing so could leave UDMA capabilities disabled on the drive at hardware level)

also, try to run each HDD as master if possible (after setting your computer as described here)

HTH

Ken

Collapse -

by Sprocket In reply to

It turned out to be a motherboard fault, according to dell

Collapse -

by Sprocket In reply to Disk Drive running in PIO

This question was closed by the author

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums