Question

Locked

Dlink DWA-652 Wirelesscm.exe problems

By MGP2 ·
Hi,
I just bought a Dlink DIR-655 N router and a DWA-652 adapter for my laptop. The router setup was no problem. However, when it comes to installing the drivers for the adapter, the wireless connection manager (wirelesscm.exe) keeps crashing. I've tried disabling Windows Wireless Zero Config service, but no luck. I've uninstalled & reinstalled and still get the same problem. So for now, I'm using my Dlink DWLG-650M adapter, which is what I was using with my previous router, the DI-634M. Has anyone else had any problems with th dwa-652 adapter or the associated drivers?

Thanks,
MGP

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

have you tried...

by -Q-240248 In reply to Dlink DWA-652 Wirelesscm. ...

The latest drivers from dlink? What kind of error message do you get when it crashes?

Collapse -

Only 1 driver - shipping version

by MGP2 In reply to have you tried...

Hi,
Unfortunately, the only driver on their site is the one that came on the cd. I did get the card working by going against their advice, which is "install software first, then install hardware." I installed the hardware and let the "Found new hardware" wizard prompt me for the driver. Funny thing is, on the times when I was attempting a full install, the wirelesscm.exe would fail before I was finished installing and (get this), the installation would end saying "installed successfully".
Anyway, I just emailed Tech Support. I'll see what type of response I get.

Thanks,
MGP

Collapse -

Been there; regretted that!

by dprice_2000 In reply to Only 1 driver - shipping ...

Hi,

I've had the same issues with the d-link wireless adapter.
It tries to install the connection manager (wirelesscm.exe) and crashes. Also, at start-up it tries to load it and gives the same crash message.
I have yet to be able to connect to the internet. I get this mysterious "Unidentified Network" title in the Network and Sharing page and no link to the Internet.

I await your news from their Tech Support.

regards,
Dave

Collapse -

If it isn't a problem with the software itself...

by seanferd In reply to Been there; regretted tha ...

Did you install the hardware and software in the exact order specified in the instructions?

Are you using an ethernet cable to set up the wireless connection?

Back to Software Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums