Question

Locked

DNS Doesn't clear cache

By jbelknap ·
I'm runing Win2k3 R2, SP2. The machine is my AD and DNS server for the local domain. I recently changed to a new set of IP's. I've had my service provider verify that the outside dns reflects these new IP's for my domain. This has replicated and now most of the world see's the new IP's.

The problem is, that from within my network, when I reference any dns entries for my domain, they resolve to the old IP's.

So, at the server, I've opened the dns server management tool, and clicked clear cache, I've then dropped to a cmd prompt and type ipconfig /flushdns. Nothing, same result.

I then tried, stopping the dns service and client, restarting it, running the clear cache in the mmc, and ipconfig /flushdns. Nothing, same result.

Finally REBOOT the Box. Do it all again, and Nothing.

I'm not using forwarders, I would prefer to go to the root for the lookups.

I've even used Server Tools and run the DNSCMD command to clear the cache and still nothing.

Any Ideas?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This may not be on target

by IC-IT In reply to DNS Doesn't clear cache

When you say you reference any dns entries for my domain, they resolve to the old IP's, are you talking names?
If so and if you have a WINS server, you may need to to scavenge the database and then tombstone the records (Through admin tools - Wins).

Collapse -

Tombstone

by jbelknap In reply to This may not be on target

Your reply MAY be right on. I've set the wins database to scavenge, however, I'm not sure what you mean by tombstone the records?

Collapse -

Basically it marks the

by IC-IT In reply to Tombstone

record for deletion during replication (if more than one WINS is used). here is a brief description.

http://technet2.microsoft.com/windowsserver/en/library/8fd40dad-8d31-491d-a19d-5568cecf9b601033.mspx?mfr=true

Collapse -

I assume

by lowlands In reply to DNS Doesn't clear cache

you have updated and verified all the records on your DNS server with the new IP's.

Collapse -

Cache Won't clear

by jbelknap In reply to I assume

It appears that the old ISP still had their dns running with the wrong IP's, and all our imaged machines had them listed as a secondary DNS entry, thus, when I cleared the cache, they whould roll over to the secondary dns and recache the wrong information. Once we removed the old ISP from the secondary dns on ALL machines, cleared the cache again, and scavenged the WINS server, all worked well. THANKS for all the ideas and help guys!

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums