General discussion

Locked

DNS help

By maisonhughes ·
I recently installed a server to host microsoft exchange. The problem is that it is taking a long time to connect to exchange. When I ping the server I noticed that it is going out on the internet to connect which is why it is taking so long. When I change my preferred dns to point to the server it is very quick but then I do not have internet access. I am not familiar with DNS and am not sure what I need to do. Should I set my Windows 2000 server to forward on to the internet? If so, how do I do this?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to DNS help

a quick and dirty way is to multihome the DNS server.

Collapse -

by sgt_shultz In reply to DNS help

see if this helps. from a great article from suppport.microsoft.com mskb 300386
Troubleshooting
Make Sure That This Server Provides the Only DNS Services for Your Network
If Windows 2000 does not detect any DNS servers during the initial DNS configuration, the new DNS server is designated as a root server. The root server is the ultimate authority for all name-resolution queries. Therefore, it is unable to deal with the concept that any name resolution queries that it is unable to answer should be forwarded to another server (or to the root servers on the Internet). Consequently, a Windows 2000-based DNS server that has been configured as a root server disables the options to add forwarders.

If this DNS server should be integrated into a larger DNS environment such as the Internet, you must remove the root forward lookup zone.

To remove the root forward lookup zone:
Click Start, point to Programs, click Administrative Tools, and then double-click DNS.
Expand the DNS server.
Expand Forward Lookup Zones.
Click the zone that is marked with a period (.), and then press the DELETE key.
Click OK.

Collapse -

by sgt_shultz In reply to

ok. what he said. and also, isn't no internet a symptom of not having the dns server's dns settings set to itself

Collapse -

by dmiddltn In reply to DNS help

Don't do either of these two options above...
Do this:
Point the server in question to the server
Go into DNS on the server
Right click your server
Click Properties
Check Enable forwarders
Put in your DNS addresses for your ISP
-Done

BTW.. all servers and workstations should then point to the DNS server here, and only that DNS server.

Collapse -

by curlergirl In reply to DNS help

Both of the previous answers are partially correct. If your DNS server is set up as a root server, you need to remove that, as described by schultz. Your DNS server(s) should be AD-integrated, and be set to their own IP addy in the TCP/IP DNS settings. All of your internal workstations and other servers should be configured to point to this (these) DNS server(s). You do not need forwarders, but make sure your root hints tabs is properly configured, showing all 13 root servers (a.root-servers.net through m.root-servers.net) and their IP addresses - to check, right click the server name in the DNS management console, click Properties, click the Root Hints tab. The only things forwarders do is speed things up a little, and save your local DNS server from having to cache DNS information. So, you can use them - it doesn't hurt - if you prefer.

Hope this helps!

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums