General discussion

Locked

dns not working properly

By kamalmatta ·
hi all,

i have setup dns server on rh 7.1. after this setup i am able to use it for the proxy client as well as gateway clients on my network properly.
if i do nslookup www.hotmail.com it gives proper result but if i give nslookup ppur.matlani.com where ppur is the host and matlani.com is the domain of same server, it does not return result.

what could be the reason ?

secondly when i do nslookup, it shows the ip address of the server rather than the name of local server. like the result of nslookup www.ndtv.com shows the following
server : 128.0.0.10
address : 128.0.0.10#53

non authoritative answer:
name : www.ndtv.com
address : 210.210.21.178

i think it shoud show
ppur.matlani.com instead of 128.0.0.10 in the name.

what could be the reason ?

thanxs
km

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

dns not working properly

by rasjani In reply to dns not working properly

The reason most likely (as you dont describe it) is that you havent really setup local zone for matlani.com. And if you are, then probably you have something totally wrong in your named.conf (usually resides in /etc )

Also, you dont really mention what dns server you are using but then again, its propably bind.

So lets think that its bind you are using. Start your editor with /etc/named.conf and and following few lines to it:

<snip>
zone "matlani.org" IN {
type master; file "matlani.zone";
notify no;
};
</snip>

In that file, there should be allready a section named "options". Now check out what's after directory in that section. Then start editing a filed called "matlani.zone" on *that* directory you found in options section.

Here's example what kind your matlani.zone can look like:
<snip>
@ IN SOA ns.matlani.com. hostmaster.matlani.com. (
2001121201 ; serial, todays date + todays serial # 8H ; refresh, seconds
2H ; retry, seconds
4W ; expire, seconds
1D ) ; minimum, seconds
; NS ns
localhost A 127.0.0.1
ppur A 128.0.0.10
ns CNAME ppur
</snip>

And then, restart your bind ( /etc/init.d/named restart )

Back to Linux Forum
1 total post (Page 1 of 1)  

Related Forums