Question

Locked

dns on windows 2003 server

By fox_x ·
Hello,
I have a very strange problem -

I have a server which is Windows 2003 Server, which is also the dns, dhcp and gateway (via Ras) to the other clients (all are windows XP). The subnet of my lan is 10.0.0.x

In the server's DHCP configuration, it's written that the dns server is the server, meaning 10.0.0.10.

Ever since few days ago, when a computer starts - I open ipconfig and there the DNS server is 192.168.1.1 (pinging to this address does not answer) - even though in the DHCP server the setting is on 10.0.0.10. On all other settings (dhcp/default gateway) - the setting is correct 10.0.0.10.

When I do ipconfig /renew, the DNS servers setting is changed to 10.0.0.10 and all is working well, though after about 40-50 minutes, again the DNS setting is changed automatically to 192.168.1.1.

Anyone has any idea ?

There is no relevant message in the server's event viewer.

Thanks,
Yoav

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Rogue DHCP Server

by Churdoo In reply to dns on windows 2003 serve ...

I am certain that you have a rogue DHCP server on your network. Judging by the appearance of the so common 192.168.1.1 IP, my guess is that someone put an off-the-shelf router appliance or wireless router appliance and it's conflicting with your production DHCP service. Find this device and either remove it, or configure it properly so that it is not servicing DHCP and your trouble is over.

I know it sounds strange that only the DNS settings are affected, but I have seen exactly this same behaviour with a such an appliance on the network.

Collapse -

possible

by fox_x In reply to Rogue DHCP Server

Thanks for the reply,
I'll expand my story if I may :) -

I brought a wireless router to this network. the router's ip was 192.168.1.1, and right away I changed its IP to 10.0.0.13 to be on the same subnet of my net, and I disabled it's option as a DHCP server.
Like this the network worked well for about 10 days, when suddenly my problem started.

Right away when it started - I took this router out of the net but the problem continued. I tried to close all the workstations, then to turn only one of them on - but the problem remained...

So it's weird because I cannot find any single computer that is generating this problem...

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums