General discussion

Locked

Documents folder in My computer

By robert_aus ·
I recently upgraded to winXP and all is going real well. I created a seperate partition for my documents, etc, as I need to access them from linux (system is NTFS, documents are FAT32). I mounted the partition under the folder /documents and settings/robert - robert being my user name.

My problem is that when another user logs on, the can access all my files through the shortcut in my computer, how can I get rid of this icon?
Thanks.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Documents folder in My computer

by kyleknicks In reply to Documents folder in My co ...

try hidding the icon.. right click on it and click on hide

Collapse -

Documents folder in My computer

by robert_aus In reply to Documents folder in My co ...

see answer 2

You can hide the directories on a FAT32 volume but anyone can still see them if they have view hidden files/folders checked in their browser.

Collapse -

Documents folder in My computer

by BobHo In reply to Documents folder in My co ...

Unfortunately, XP's security features only work on NTFS volumes. You can hide the directories on a FAT32 volume but anyone can still see them if they have view hidden files/folders checked in their browser.

To secure FAT32 volumes you'll need to get a third-party security app like FolderGuard. Here's a link:

http://www.winability.com/folderguard/

Enjoy,

DrBob:&gt

Collapse -

Documents folder in My computer

by robert_aus In reply to Documents folder in My co ...

yes, but if they don't know its there they won't try and get in. the only link to it at the moment is the link in my computer.

Collapse -

Documents folder in My computer

by BobHo In reply to Documents folder in My co ...

Unfortunately, FAT32 volumes do not allow security settings like NTFS volumes. yes you can hide them, but anyone can still see and access them if they have view hidden fiiles/folders turned on.

I think you will need to use a 3rd party program like FolderGuard. Here's a link:

http://www.winability.com/folderguard/solutions.htm

Check it out and see if it works for you.

Enjoy,

DrBob:&gt

Collapse -

Documents folder in My computer

by robert_aus In reply to Documents folder in My co ...

Poster rated this answer

Collapse -

Documents folder in My computer

by WGS In reply to Documents folder in My co ...

The "My Documents" shortcut is controlled by CLSID {450D8FBA-AD25-11D0-98A8-0800361B1103}.

A key in the namespace of the Desktop or Computer adds the "My document" functionality to the File-Open and File-Save(as) dialogues and the explorer.

Toprevent this remove the key with the name {450D8FBA-AD25-11D0-98A8-0800361B1103} from the hive HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\Namespace\ (or rename the key by putting a collon in front of the keyname).

As noted inearlier answers its only a cosmetic change. Knowledge of the actual path gives any user access to your files.

Regards, Wim

Collapse -

Documents folder in My computer

by robert_aus In reply to Documents folder in My co ...

thanks. thats what i wanted to know.

Collapse -

Documents folder in My computer

by robert_aus In reply to Documents folder in My co ...

This question was closed by the author

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums