General discussion

Locked

DOS Compatibility ?

By cyberghost_1 ·
I was updating some stuff on my PC, After restarting, I noticed that my Desktop Theme Sounds weren't working, start-up screen didn't function and my custom pointers won't funcion. In Control Panel under the Performance Tab I get a messege that my file system and virtual memory are using MS/DOS Compatibility.....HOW DO I CHANGE THAT SETTING??

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to DOS Compatibility ?

you can't change it, you gotta fix whatever is causing it to run in compatiblity mode. usually ide driver is bad or something...
how are things looking in Device Manager? any bangs, x's or exclamation marks?
you upgraded some stuff. boy, that helps. (rdl)
did you upgrade your directx drivers?
if so, maybe you have overreached capability of your older video card?
in any case, easy to disable directx for test. Start/Run/dxdiag <enter>. then disable everything by sliding sliders all the way to left as prompted.
btw, i would expect directx thing to affect cursers and themes and sound but not put your hd in compatibility mode. so maybe you have multilple things going on... i would boot in safe mode after peeking at device manager to see what got 'fixed' (if anything) running that way.... my suggestion is look up 'troubleshoot compatiblility mode' for your os at support.microsoft.com in the knowledgebase for further help)

Collapse -

by cyberghost_1 In reply to

Poster rated this answer.

Collapse -

by TheChas In reply to DOS Compatibility ?

The switch to MS-DOS compatibility mode often happens when the wrong driver for the chip-set on the motherboard is installed.

I have seen Windows Update suggest installing a driver that does NOT match the system hardware.

Here is a link to a Microsoft Article on MS-DOS compatibility mode:

http://tinyurl.com/2g83d

What you usually need to do to correct the problem is:

Remove your drives and IDE controllers from device manager.

Edit the registry to remove the flag that sets MS-DOS compatibility mode.

Re-boot and make sure that you install the correct driver for the IDE controller.

Another problem can be from a DOS mode CD-ROM driver loaded at startup that conflicts with the Windows IDE driver.
Unless you NEED DOS mode access to the CD-ROM, you should NEVER install the DOS driver.
If the DOS mode driver is loading, edit Autoexec.bat and / or Config.sys to disable the driver load.
(Place the characters "rem" and a space at the start of the mscdex command line.)

Chas

Collapse -

by cyberghost_1 In reply to

Poster rated this answer.

Collapse -

by RCOM In reply to DOS Compatibility ?

As mentioned it would help to know exactly what you were doing that you've called "updating some stuff on my PC". Also what is the operating system and information about the PC hardware will help too?

Can you undo the updates, that's probably the easiest way to get back to normal.

Did you make any changes to any of the settings in the "Performance Tab" options? Disabling 32 bit mode drivers can cause this problem.

The "autoexec.bat" and "config.sys" files don't need to say anything. To edit these files in Windows 9X you can run "sysedit", these are the front 2 of the cascaded windows.

For the autoexec.bat file just input "rem" in front of each line and in config.sys put a semicolon in fron of each line. Don't delete the lines just in case something is being loaded that's specific to you PC. The changes can be undone later.

Examples:

Put the word rem in front of command lines in the Autoexec.bat file.

rem c:\windows\command\mscdex.exe

Put a semicolon in front of command lines in the Config.sys file.

evice= C:\cdrom.sys

If the changes make no difference or cause other issues you can undo what you did by following the same procedures.

Make sure you have the drivers for the PC and boot into safe mode. Hit F8 just before the clouds come up when booting. Select safe mode. Right click on My Computer and select Properties then go to device manager. If the sound doesn't work at all delete the sound card. Then delete the CDROM(s), and IDE controllers. Reboot and reinstall the drivers.

Collapse -

by cyberghost_1 In reply to

THIS DID THE TRICK THNX !!!!!!!!

Collapse -

by cyberghost_1 In reply to DOS Compatibility ?

I was DLing a PROG call FRESH UI. As well as DLing Drivers from Compaq. I still cant fix it...I tried REFEDIT, with no success...Didn't detect any NOIDE or BAD_IDE file. Now What??

Collapse -

by cyberghost_1 In reply to DOS Compatibility ?

I think I figured out what prog caused this. I DL VIA_Hyperion 4IN1_V451v.zip This is a 4 in 1 Driver Chipset. It updates Reg Drivers BIOS, VxD. Now I am sure that after installing this is when the problem occured. Now, how do I undo what this did?

Collapse -

by cyberghost_1 In reply to DOS Compatibility ?

After attempting to Install this Program I get an Error MSG stating the following: Registry Error PLease ReBoot.

Collapse -

by cyberghost_1 In reply to DOS Compatibility ?

This question was closed by the author

Back to Desktop Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums