General discussion

  • Creator
    Topic
  • #2176833

    dos names corruption within ntfs

    Locked

    by sebastian.koch ·

    On our data server we backup disk to disk with robocopy.
    In the error log there are some files with files-names with special characters which cannot be copied.
    As i found out this happens if names break the 255 limit in dos-names (if you save with the notepad as ascii) or when there is no translation of special-characters from other international ansi-codes-names.
    When i tried to delete or rename them windows cant find this files – they block the whole directory structure.

    The only way to get rid of them would be a reformat of the file system – which is not simple for the main productive system.

    Is there a way for windows 2000 to rename these hidden charcaters? (i tried zap but that didnt work – i tried renaming from command-prompt with batch file – also unsuccesfull)
    And last not least is there a way for windows 2000 to disable these wrong ascii-signs?
    regards
    Sebastian

All Comments

  • Author
    Replies
    • #3330328

      Reply To: dos names corruption within ntfs

      by bfilmfan ·

      In reply to dos names corruption within ntfs

      Which version of Robocopy are you using?

      And would the Windows 2000 NTbackup not allow you a method getting around the issue, since Robocopy will not be able to get the system state of the Windows 2000 server.

    • #3330325

      Reply To: dos names corruption within ntfs

      by sebastian.koch ·

      In reply to dos names corruption within ntfs

      robocopy version 1.96, but robocopy is just the way where the error appears.
      the backup to tape is working- but the corruption of the file-system is done from windows2000 clients not from robocopy .
      So its an issue of ntfs allowing to write dos-names which cant be accesed by windows2000.

    • #3330106

      Reply To: dos names corruption within ntfs

      by blackcurrant ·

      In reply to dos names corruption within ntfs

      Hi

      Have you tried renaming the file(s) from a command prompt with explorer stopped? There’s a TR article explaining how to delete ‘undeletable’ files here:

      http://techrepublic.com.com/5100-6346_11-5288922.html?tag=search

      Perhaps by turning explorer off you will be able to rename the file.

      Good luck

Viewing 2 reply threads