General discussion


dos names corruption within ntfs

By sebastian.koch ·
On our data server we backup disk to disk with robocopy.
In the error log there are some files with files-names with special characters which cannot be copied.
As i found out this happens if names break the 255 limit in dos-names (if you save with the notepad as ascii) or when there is no translation of special-characters from other international ansi-codes-names.
When i tried to delete or rename them windows cant find this files - they block the whole directory structure.

The only way to get rid of them would be a reformat of the file system - which is not simple for the main productive system.

Is there a way for windows 2000 to rename these hidden charcaters? (i tried zap but that didnt work - i tried renaming from command-prompt with batch file - also unsuccesfull)
And last not least is there a way for windows 2000 to disable these wrong ascii-signs?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by BFilmFan In reply to dos names corruption with ...

Which version of Robocopy are you using?

And would the Windows 2000 NTbackup not allow you a method getting around the issue, since Robocopy will not be able to get the system state of the Windows 2000 server.

Collapse -

by sebastian.koch In reply to dos names corruption with ...

robocopy version 1.96, but robocopy is just the way where the error appears.
the backup to tape is working- but the corruption of the file-system is done from windows2000 clients not from robocopy .
So its an issue of ntfs allowing to write dos-names which cant be accesed by windows2000.

Collapse -

by Blackcurrant In reply to dos names corruption with ...


Have you tried renaming the file(s) from a command prompt with explorer stopped? There's a TR article explaining how to delete 'undeletable' files here:

Perhaps by turning explorer off you will be able to rename the file.

Good luck

Related Discussions

Related Forums