General discussion

Locked

Drive Install Changes BIOS?!!

By KahunaNui ·
I've never seen anything like this. Client's system is an ASUS P4C800-E Deluxe with no SATA. One WD800JB 80GB drive as single/master IDE Primary and one WD2000JB 200GB drive set as single/master on the Promise controller (set to IDE - NO RAID). Everything is find with this setup. UNTIL, I swap the IDE WD800JB for a WD1200JB (120GB) drive. THEN, when the system boots, the WD2000JB in the Promise Sata/IDE controller is now THE FIRST DRIVE (DRIVE 1) and the WD1200JB in the Primary IDE channel is DRIVE 2, which hoses up the entire system and of course will not boot.

Now when I swap the drives back the way they were, the WD800JB in the IDE channel is again DRIVE 2 and the drive in the Promise controller is again DRIVE 1. I HAD TO RESET THE RTC RAM (CMOS) for this to revert back the way it is supposed to be.

Is this a simple drive incompatibility or a MB problem? Why would just installing this drive change how the CMOS sees the drive config including THE ORIGINAL config?!! From the time that WD1200JB drive is installed, every single drive installed as Primary in the IDE channel shows up as the SECOND drive (the drive in the Promise channel is the first drive).

What does this drive change in CMOS to force a RESET to get it back to normal?!

Thanks in advance

This conversation is currently closed to new comments.

16 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by TheChas In reply to Drive Install Changes BIO ...

When you install a "new" drive as Primary Master, I assume that it is not partitioned or formatted.

When the BIOS finds an invalid boot device on the Primary Master position, it will search for a valid device to boot from.

Why it does not default back to the "C:" drive when switch drives back is a bit of a mystery.

You might want to check the boot device sequence settings.

I further suspect that at some point the user had installed Western Digital's Easy BIOS software.
It is likely Easy BIOS that is changing the BIOS boot sequence for you, and / or overpowering the BIOS boot device settings.

Another distinct possibility is that the Promise card is forcing a BIOS change when there is not a valid boot device present as the Primary Master.

Pull out the Promise card and see what happens when you swap IDE drives.
If they behave as you expect, it is a feature of the Promise card that is changing the BIOS settings.

If the problem persists, one or more drives have Easy BIOS, or some other drive overlay software installed.

To purge the system of the drive overlay software, boot from a WD utility CD, with a WD drive as the Primary Master device and choose to fully remove Easy BIOS and whatever other software WD installed on the drives.

Chas

Collapse -

by KahunaNui In reply to

Please see additional comments above.

Collapse -

by willcomp In reply to Drive Install Changes BIO ...

Good info from Chas. Would help to know whether drives are formatted and whether Windows is installed or has been installed on drives.

It appears that BIOS is trying to find a bootable hard disk.

Assume that Promise controller is an on-board rather than add-in controller. If that's not the case, let us know.

Dalton

Collapse -

by KahunaNui In reply to

Please see additional comments above

Collapse -

by KahunaNui In reply to Drive Install Changes BIO ...

Ok, thanks for the responses: Please note:

1. The drive that SHOULD be showing up as Drive 0 (the primary IDE drive) is formatted with primary active partition. Second drive is formated as EXTENDED with a few logical partitions. So there is no reason that it shows up as the first drive in front of the primary single IDE drive.

2. No BIOS overlay (EZ-BIOS or anything like it).
3. Promise controller PDC20378 RAID/IDE/Ultra-133 is ON BOARD as you mentioned. Not an add-in card.
4. I haven't yet tried any other drives to see if it's this particular drive (the 120GB WD) that causes the problem. Don't have any other drives to test with it.
5. I ended up installing the WD1200JB as Slave with the WD2000JB as Master on the Promise on board controller. Now I worry that if we are able to swap drives at all.
6. System is equipped with a REMOVABLE DRIVE setup using CRU DataPort storage modules. Used this removable drive setup for years and we've never seen this happen before?!!
7. There is a SLIGHT possibility that it is the drive enclosre itself causing this, however, I've used this particular drive enclosure without any problems in the past with 40, 60 and 80GB drives.

Collapse -

by TheChas In reply to Drive Install Changes BIO ...

On-board RAID controllers are more tied into the BIOS than plug-in boards are.

Are the drive assignments changed on the POST screens?

Or, do you see the drive assignment changes while the OS is loading?

For that matter, what OS is on the system?

If the OS is Windows XP, XP could be at the root of the issue.
This would only be possible if the 200GB drive is a bootable volume with XP system files installed.

Give this a try.

Boot from a startup floppy, or with a CD with JUST the 120GB drive installed.
Format the drive using the /s switch to install the system files.

Connect the other drives back up and see if the system boots properly.

You may need / want to check BIOS settings for both the motherboard and the Promise controller.
Make sure that SCSI and on-board Promise or RAID are NOT listed in the available boot devices.

Chas

Collapse -

by KahunaNui In reply to

Sorry Sir Chas!! No XP, OS is Win2000. Also, I tried installing with only system files... no go. There is no option in BIOS to boot from the Promise controller. Thats not the problem. I am now leaning toward either the drive itself, or the removable carrier as the culprit. When I get another drive, I'll test that theory.

Collapse -

by HAL 9000 Moderator In reply to Drive Install Changes BIO ...

The problem is that you have the second HDD installed on the Raid Controller and the BIOS is defaulting to the Raid Controller for a boot drive. If you install this drive on the Primary IDE Channel as a Slave drive everything should work OK but if you can not do this for reasons of cable length you'll have to reset the BIOS to only boot from the IDE controller and not the Promise Raid Controller.

This ASUS M'Board has an Intel 817 Chip set so it by default looks for a Raid Array even if there is not one set and what has most likely happened in this case is that the drive that you are removing already has a subroutine on it telling the BIOS to look at the primary IDE channel for the Boot disk. When you install another drive this is missing and the BIOS defaults to its primary settings and looks for a Raid setup to boot from hence the problem that you are experiencing.

You should be able to reset the boot sequence in the BIOS setup to over come this particular problem it should be set to boot from A then Primary IDE then Secondary IDE and disable every other boot option. That should cure your problem.

Col

Collapse -

by KahunaNui In reply to

Yes, it is impossible to stretch that cable between this removable carrier and the Promise controller (all the way at the bottom). Again, no option in BIOS for booting from Promise - had already checked that. You may have something with the "subroutine" on the original 80GB WD drive. How do I check that? As far as "Boot Priority" in BIOS goes, only choices are: Floppy, CD, IDE HDD. Thats the order I put them in as well. Once this swap was made, the WD 120 GB shows up as the second drive in all diag programs: Microscope, PC-Check, Partition Magic, etceteras. The POST is far too quick for me to see, and I haven't paused it to check. Fact is that the 120GB drive does this weirdness, and it takes a full clearing of CMOS to return system to normal. The 80GB drive doesn't do this. I will try switching carriers to see if that's the culprit (don't know how it could be but stranger things have happened).

Collapse -

by willcomp In reply to Drive Install Changes BIO ...

Light bulb on! Since these are all WD drives, how are they jumpered? When a WD IDE is jumpered as master, it must have a slave attached. Will not boot from a single WD drive on IDE channel jumpered as master.

To keep things simple when dealing with WD IDE drives, I set jumper to cable select and let cable position handle the master/slave relationships.

To set a single WD IDE drive as master, remove all jumpers.

I am assuming that drive models are correct (JB) and all are IDE drives with no SATA drives in mix.

Dalton

Back to Desktop Forum
16 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums