Question

Locked

Dropping a connection while file transfers - Solved

By James Schroer ·
Running a windows 2003 SP2 server with a few file shares. The set up is a little complex but nothing that is really out of the ordinary. The issue is when I'm copying files from my laptop to this server I get an error stating the connection is dropped. When doing a trace route to the server I have 6 hops and I'm sure there are a firewall or two in the middle of me and the server. But I can copy to other systems in the same network as the server with no problem. ALSO I can copy from other systems in the same network as that server with no problem. Also I can ftp to that server with no probems from my laptop.

I did a network trace and did see that it must of lost some packets. Why would it be doing this to my server and not to others in the same network and why can I transmitte inside the same network with out any issues.

I'm at a complete loss as to why I'm dropping the connection. Any ideas would be great. Thanks

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

To clarify:

by robo_dev In reply to Dropping a connection whi ...

Is this over a private WAN, or the Internet?

You have six hops from a server on a private WAN to your laptop? (that's a big wan)

Have you tried a different ethernet card/cable/and a different ethernet switch port?

If the port is mis-negotiating (e.g. connecting at 100/half to 100/full port) then there will be lots of CRC errors and dropped packets. Local server connections can get through, but these errors get too much when latency gets higher.

Get an old laptop and load up a copy of WireShark (free protocol analyzer). This would show any network problem very quickly.

Collapse -

Yes large WAN

by James Schroer In reply to To clarify:

Priviate WAN and yes from my understanding it's a very large WAN. The box is on the development side of things and my laptop is on the corp prod side of things.

I have tried a different nic and switch port and differnt IP. What I did was set up a second nic and IP for testing and getting the same results.

I've had the switch checked and compaired setting with the NICs to make sure they were set correctly and they are.

I have WireShark on my laptop and ran with the error coming up. The only thing I really found was this line that read...

microsoft-ds > 4617 [RST] Seq=419383 Win=0 Len=0

It looks like it gives any where from 2 to 5 of these when I get the error. But I haven't found anything on this. It' looks like it trys to do a reset on the connection and just drops it.

Collapse -

That RST looks like a normal event

by robo_dev In reply to Yes large WAN

That would happen if the connection were timing out (like what you're seeing).

One guess is that the server's DNS settings are messed up. DNS Lint utility may help:

http://support.microsoft.com/default.aspx?scid=kb;en-us;321045

Does that server use nic teaming?

Can you copy files FROM that server?

Does the server do virus scanning?

Do you have mutiple lan adapters in your laptop? Are they both active? (e.g. wlan and lan)

Collapse -

Not using DNS

by James Schroer In reply to That RST looks like a nor ...

I'm not using DNS to get to this server I'm going directly to the IP. i.e. \\ipaddress\sharedfolder But to make sure it wasn't a DNS issue I've also added it to my host file.

The server does not use nic teaming on either of the the two nics I have set up.

I can NOT copy from this server I get the same error. BUT if I log onto the server I can push and pull to and from my laptop with no problems.

Yes I have multiple adapters but I have the wireless turned off.

I'm not familiar with the RST in the trace. When looking it up it looks like it resets the TCP connection. Wouldn't that drop my file copy?

Collapse -

More information

by James Schroer In reply to Dropping a connection whi ...

I've found out more information that I wanted to pass along. I think this is out of my hands now and into the network guys hands.

I found out that while doing a copy it would drop my connection when someone else connects to that share but only from our other domain. Apparently they do some sore of NAT from the other network to the one this is on. I looked at the ports from the NATed address and they are different so I'm not sure why it's dropping it. BUT in knowing that we are actually able to reproduce the same issue on another server.

So I'm not sure what's going on with the firewall/router side of things but what ever it's doing windows doesn't like and must think it's the same session and the one doing the copy.

Collapse -

Solution...

by James Schroer In reply to Dropping a connection whi ...

Windows 2003 does not like smb connections over SMB. M$ fixed it with a patch in W2K but not in 2003. But they do have a reg hack that fixes the issue. Check out this article.

http://support.microsoft.com/kb/301673

Collapse -

Good information

by robo_dev In reply to Solution...

If it's possible to do, add the word (solved!) by editing the title of your original post... more people will learn from that.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums