General discussion

Locked

Dropping Wireless Internet Connection - Until Re-boot

By colby.d.smith ·
I have seen many people with this same problem but none of the suggested fixes seem to work for me. I am not an expert at all when it comes to setting up networks or wireless technology (so please go easy on me). I set up my network which consists of a desktop, cable internet, wireless router and a laptop with wireless card. I am able to connect to the internet, however, my internet connection seems to drop multiple times a day and the only way to repair it is to reboot my laptop.

My connection usually drops if we haven't used the laptop for a few minutes. I thought maybe it was a power management thing but I have tried the suggestions of other to no avail.

I always can connect (or pick up) my connection to my router but my laptop doesn't seem to recognize my internet connection until after I reboot. I should say that rebooting fixes the issue 90% of the time. The other 10% of the time, it still won't connect at all.

I have no idea what is going on. My internet comes through a cable connection. I have a Dell wireless router, Dell Inspiron 1150 laptop and a Dell Wireless 1450 Dual Band WLAN Mini-PCI Card. I have downloaded the latest drivers for my wireless card from Dell but this has not fixed the problem.

Please help before I pull the rest of my hair out!

Any help would be greatly appreciated.

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Same Problem

by The_Lucky_One In reply to Dropping Wireless Interne ...

I am setting up a Dell M1710 with an Intel WiFi 4965AGN. I also just set up a Belkin N1 Wireless Router, configured with security. The connection drops to local only. I have to disconnect and connect to get full access again. I would like to ultimately use Intel's wireless connection software, but **** if I can figure out how to! After reading all the posts, this seems to be a common prob. Can Anyone Help?

Collapse -

Same Problem Also

by guyfromhi In reply to Same Problem

Hello,

I am experiencing the same problem. My system is a Dell XPS M1710 Notebook with Windows Vista Premium. I have an Intel Wireless 3945ABG card and use a Belkin wireless router. I wish I had a solution, but I don't. I am hoping that 1) Dell picks up on the fact that the majority of people experiencing this problem are Dell notebook owners, and 2) we can narrow down the culprit by comparing what the failing systems have in common (i.e. Intel wireless cards, in Dell notebooks, with xx brand routers).

By the way, I spent over an hour with Dell tech support this evening, to no avail. Argghh!

Thanks

Collapse -

I haven't heard anything from the user since I made some changes

by The_Lucky_One In reply to Same Problem Also

I talked to Belkin and we flashed the firmware plus I also loosened up the security, and I haven't heard back from the owner yet. Did you update Belkins firmware?

Collapse -

A few questions

When you say you lose Internet is that just to the notebook or to the desktop as well? What happens when you eliminate the wireless router and just use wired connections to the cable modem?

Is the wireless router the DHCP server or is the cable modem the DHCP server? Have you tried different channels? Is encryption enabled? If so have you tested with encryption disabled? Are there any hot spots nearby where you could go and see if the notebook works correctly?

Sorry if all of these questions are redundant, but you did not really let us know all that you have tried.

Collapse -

Thanks for replying

by colby.d.smith In reply to A few questions

The disconnection occurred again tonight so I will describe what occurred and I will also attempt to answer the questions you have asked.

I was using my laptop today with an active internet connection via my wireless router. When finished, I closed the lid and went about my business for the afternoon. As I said before, my laptop sometimes drops it's connection sporadically even while I am using it, however, it seems to occur most often if the laptop goes into standy-by or hibernation mode. I don't know if this is related or not. This would be fine if I could simply repair my internet connection but it seems that I usually have to reboot.

Today when I returned and tried to use my laptop, I had to bring it out of hibernation and could not acquire an internet connection. I tried to repair the wireless connection numerous times with no luck. The laptop was reporting that it was Connected with a Signal Strength of "Excellent" at a Speed of 54.0 Mbps but I couldn't connect to any webpage with a browser.

I even tried sitting with my laptop directly beside my wireless router but I still could not access the internet.

Then something strange happened. I then began using the internet on my desktop bnecause my laptop had no internet connection. After about an hour, my laptop connected on it's own without a reboot. Now this puzzles me even more.

The following are my answers to the questions you posed. Sorry if I am not as informative as possible. As I said, I have limited experience.
--------------------------------------
Q1. When you say you lose Internet is that just to the notebook or to the desktop as well?

A1. I have never had a problem accessing the internet from my desktop only the laptop via a wireless connection.

Also, my set up works like this: I have a Motorola cable modem. A LAN cable runs from it's Ethernet port into the Internet port of my Dell wireless router. I then have a LAN cable running from the LAN1 port on the Dell wireless router to the network card on my Desktop.

Also, when I say that I can't "access the internet" from my laptop, I mean that although the status of the Wireless Network Connection on my laptop says that I am Connected and the strength is Excellent, I cannot access any web pages.

Q2. What happens when you eliminate the wireless router and just use wired connections to the cable modem?

A2. If I take the wireless router out of the equation and plug the network cable from the Motorola cable modem directly into my laptop, my laptop obtains a successful Local Area Connection with a speed of 100 Mbps and I am then able to access web pages (I think my wireless router limits my connection speed to 54 Mbps).

Q3. Is the wireless router the DHCP server or is the cable modem the DHCP server?

A3. I don't know how to tell whether the cable modem or the wireless router is the DHCP server. I am assuming it's the cable modem because the wireless router was not a requirement of my ISP.

Q4. Have you tried different channels?

A4. No, I have not tried different channels yet. I am assuming that this is done with software for the wireless router. I used Dell's software to initialling install the router but there doesn't seem to be any configuration utilities on the Desktop to modify these settings. If there is somewhere else that these can be modified, please advise and I will try.

Q5. Is encryption enabled? If so have you tested with encryption disabled?

A5. As far as whether encryption is enabled, I may be wrong but I am assuming that you are asking whether this is a secure wireless network? If so, yes it is a secure network. If this is not what you meant, please let me know how to enable/disable encryption and I can check. I have not tried to connect to a non-secure network.

Q6. Are there any hot spots nearby where you could go and see if the notebook works correctly?

A6. There are no hotspots where I currently live. My old workplace was a hotspot and I never had an issue connecting there. Unfortunately, that doesn't really help here.

Again, I rally appreciate you posting back and taking a look at my issue. I still don't understand why my Wireless Network Connection is reporting that I am connected and then I cannot get any internet access. Furthermore, I am puzzled how my laptop started accessing the internet on it's own after an hour or so without me rebooting it.

Any further help would be greatly appreciated. Thanks

Collapse -

Good Post

by Michael Kassner Contributor In reply to Thanks for replying

Thank you for the in depth answers. To begin--I am not sure--but it is my understanding that when in suspend or hibernation mode the network adapter shuts down. So that maybe normal.

The next step will require you to get to a a command prompt. That can be accomplished by Start/All Programs/Accessories/Command Prompt. At the Command Prompt type in ipconfig /all. In your next post please copy and paste the information from the response. Also note down what is called the IP address (XX.XX.XX.XX) for the Default Gateway. While still at the command prompt, please try the command: ping 127.0.0.1. I just want you to become familiar with the response from the ping command.

The next time the note book loses Internet connection, go to the Command Prompt and execute the ping command using the IP address of the Default Gateway and see if you get the appropriate response. If not then you are not associated with the wireless router. If it does work then try ping www.yahoo.com. I suspect you will not get a response, because if you do then you should be able to access that web site. If there is not an appropriate response try the command ping 69.147.114.210, which is the IP address associated with www.yahoo.com. If that works then the problem is related to DNS and we can look into that. If the ping command still does not work then you have a different issue.

You need to learn how to access the web based configuration screens on the wireless router, I am not that familiar with the Dell products, but you should be able to enter the Default Gateway (which is the wireless router) IP address into a web browser and the initial page and login should come up. I am not sure what username and password if any was configured. You need to determine that and log on, then we can learn how the wireless router is configured.

Collapse -

Here are the results

by colby.d.smith In reply to Good Post

Hi Michael,
I have tried the things you have suggested and here are the results:

Response from IPCONFIG/ALL:
---------------------------
Windows IP Configuration

Host Name . . . . . . . . . . . . : Laptop
Primary Dns Suffix. . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP ROuting Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller
Physical Address. . . . . . . . . : 00-11-43-61-53-A9

Ethernet adapter Wireless Network Connection:

Connection-specific DNS suffix . :
Description . . . . . . . . . . . : Dell Wireless 1450 Dual Band WLAN Mini-PCI Card
Physical Address. . . . . . . . . : 00-11-F5-19-87-37
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.2.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . : 192.168.2.1
Lease Obtained. . . . . . . . . . : August 19, 2007 8:25:45 AM
Lease Expires . . . . . . . . . . : August 20, 2007 8:25:45 AM

Ethernet adapter {539ECF63-6FF8-487B-847C-F5FF15F78AD9}:

Connection-specific DNS suffix . :
Description . . . . . . . . . . . : Nortel IPSECSHM Adapter - Packet Scheduler Miniport
Physical Address. . . . . . . . . : 44-45-53-54-42-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :

Pinging 127.0.0.1
-----------------
I then successfully Pinged 127.0.0.1 (4 packets sent/4 received). I tried pinging this address when I am connected to the internet and also when I cannot establish a connection. I get the exact same response for both situations.

Pinging Default Gateway (192.168.2.1)
-------------------------------------
As above, I was able to successfully Ping 192.168.2.1 (4 packets sent/4 received). I tried pinging the Default Gateway when I am connected to the internet and also when I cannot establish a connection. I get the exact same response for both situations.

Ping www.yahoo.com
------------------
I tried pinging www.yahoo.com when I am connected to the internet and also when I cannot establish a connection. I did get different reponses for this.

When I was connected to the internet, I was able to successfully the address (4 packets sent/4 received).

When I couldn't establish an internet connection, I received the response "Ping request could not find host www.yahoo.com. Please check the name and try again.".

Pinging 69.147.114.210
----------------------
As you suggested, I also attempted to ping Yahoo's IP Address 69.147.114.210. This was successful regardless if I could connect to the internet or not (4 packets sent/4 received). I get the exact same response for both situations. From your post, you have suggested that this issue is related to DNS.

Wireless Router Configuration
-----------------------------
I have found out how to access my router's configuration via a web page so I can provide additional information if requested.

Thanks again,
Colby

Collapse -

Good information

by Michael Kassner Contributor In reply to Here are the results

As you surmised it appears to be a DNS problem. DNS amounts to the ability to change a people friendly name like www.yahoo.com into a network friendly number called the IP address.

One last test would be to use the IP address for www.yahoo.com in the address bar of the web browser you use. If you can get to the site then there is definitely a DNS issue.

What you need to do now is get into the configuration web page of the router and determine if you are receiving the information required for the Internet facing interface automatically from the ISP or if that was configured by you and the settings are static.

When you know this get your ISP involved as they need to give you two IP addresses one for the primary and one for the secondary DNS server. As that information may not be configured correctly on the router or the ISP is having issues with their DNS servers.

After you configure that information you can try pinging www.yahoo.com. If that works then you should have Internet access via the web browser.

Collapse -

Definitely DNS

by colby.d.smith In reply to Good information

Hi Michael,
It appears that this is definitely a DNS issue. Whenever I can't access a web page (i.e., www.yahoo.com) I then try to access the page with the IP address for Yahoo that you provided (69.147.114.210). I can then access the web page successfull, however, none of the links will work because they try to resolve the associated "user-friendly" internet address. Usually after connecting with the IP address for a few minutes, my connection begins to recognize the user-friendly address (i.e., www.yahoo.com) and I can use the internet again.

I have contacted my ISP (EastLink in Canada - http://www.eastlink.ca) and they stated that they are not having any problems with their DNS servers. Since I am connecting to their service through a wireless router, they won't support my connection as they say they only support a direct connection to their modem (I don't seem to have this problem when I am connected directly to the cable modem). Also, they said connection settings for TCP/IP are supposed to be set up so that both the IP addresses and DNS Server Addresses are obtained automatically. I have checked this setting for my local area connection on my laptop and this is set correctly (hopefully I am looking in the right spot).

I have checked the configuration settings on my wireless router in regard to any DNS settings that may be available. The only settings I see are "DNS Server Status" that has lines of:

Host Name: localhost
IP Address: 127.0.0.1
Source: User-defined

Host Name: Laptop
IP Address: 192.168.2.2
Source: Automatic

The only other setting I see related to DNS is an "Enable Dynamic DNS" checkbox which is unchecked.

At this point, I don't know what I should do to resolve the issue. I have seen a comment from another EastLink user that was having similar problems and he chose to use DNS Servers from http://www.opendns.com/.

I have also found a website called Bad DNS (http://www.baddns.com/pubservs.html) that has included two EastLink DNS servers (m5.eastlink.ca. - 24.222.0.5 and z3.eastlink.ca. - 24.222.0.33) where they state that "These servers have been found to answer public recursive DNS queries, and are well behaved".

Should I be trying to statically name a Primary and Secondary DNS Server although my ISP states that these should be obtained automatically?

Collapse -

Thought so

by Michael Kassner Contributor In reply to Definitely DNS

It sure sounds like your wireless router is not publishing the DNS address. I might suggest a test of sorts. In the TCP/IP properties of one of your computers add the DNS server IP addresses statically. But leave the "obtain IP address automatically" box checked. If the problem does not appear then the wireless router is not functioning correctly.

I can not remember if you mentioned whether or not you have the latest firmware installed on the router? If not that should be done, albeit carefully so as not to brick the device.

If the problem persists, try using those first DNS server IP addresses you mentioned. Those are well known and typically solid performers.

Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums