Question

DX11 Feature Level 10.0 Required to Run the Engine

By urgirlfriday2017 ·
Tags: Windows, Hardware
Just bought & installed Medieval Dynasty via Steam but it won't initialize due to the following error 'DX 11 feature lvl 10.0 required to run the engine'. I have Windows 10, GPU is NVIDIA GeForce G105M. DirectX12, feature lvls include 10.0, drivers are updated. Is my graphics card capable of supporting Direct3D Feature Level 10.0? Any suggestions on how to transcend this issue? Please help, greatly appreciated :-)
Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums