E-Mail not sending on all computers

By Cudmasters Los ·
i have a network with about 20 users, some can send e-mail but the other cannot, they all can recieve. i disconnect my cisco router, and connected another router, and nothing changed, i tried changed port 587 instead of 25, didn't help. Any suggestions?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

What kind of systems?

by TobiF In reply to E-Mail not sending on all ...

You seem to believe this is a networking issue.

In your mind, have a look at the whole situation.
Is there any common trait that unites all the computers, which can't get through?
(system version, hardware make, vlan...)

On a computer that can not send mail, try the connection to the server:
telnet (ip-adress of mail server) 587
Does the server respond
OR (better way)
Enable logging in the client and try to send mail. The log should show, step by step, what it does, and you may get a better clue of where in the process it stops (resolving host name to ip; connecting to host via tcp; establishing tls (if applicable, which would be good, but can be tricky to set up); loggin in; hand over message; get confirmation; hanging up; doing post-sending homework (delete or move message from outbox...))

Good luck!

Collapse -


by Cudmasters Los In reply to What kind of systems?

Here is my outgoing log

2010.08.18 16:56:25 SMTP ( Port: 25, Secure: no, SPA: no
2010.08.18 16:56:25 SMTP ( Finding host
2010.08.18 16:56:25 SMTP ( Connecting to host
2010.08.18 16:56:25 SMTP ( Connected to host
2010.08.18 16:56:26 SMTP ( Disconnected from host

Collapse -

Log from working?

by TobiF In reply to Logging

Can you get the same type of log from a computer where it works? That might help us to spot any difference.

Collapse -


by patb071 In reply to E-Mail not sending on all ...

Did this work before? If so what changed if not, go to tools, account settings, under E-mail tab, double click the account, more settings, and outgoing server tab. See if the setting for my outgoing server (SMTP)reguires is checked for the working users. if it is and it isn't for the non-working users thats your problem.

Collapse -


by brian In reply to E-Mail not sending on all ...

You could also put a route add in place on the pc's having a problem, telling them they must go to a particular ip range through a particular gateway (if you have more than one gateway on the network). it is a possiblity (i have to use these to distinguish between MPLS and regular internet for a propriatary program we run here).

Collapse -

Fixed, don't know how

by Cudmasters Los In reply to Routes

got it fixed, don't no how. Some computers still work on 25, the computers that would not work on 25 or 587, today they now work on 587?????

Have no clue

i had removed the router and used just my comcast modem, still had the same problem. next day, it worked??

Related Discussions

Related Forums