E6300 lag in games

By superstarpc2486 ·
I just bought a some upgrades for my computer and they go as follows, Core 2 Duo E6300, Abit Ab9 Mobo, Patriot Extreme DDR 800 ram, a 300 GB Seagate SATA Hdd, Sapphire Radeon X1300, and stock power supply

I used to play UT2004 on my athlon 64 system and it would perform flawlessly but this new upgrade has made it into half the speed of before and i feel ripped off is there any advice people can give to help me from throwing this away and get my old system back.

Please Someone Help!!!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

The weakest link

by JamesRL In reply to E6300 lag in games

The CPU is usually the last thing to have an impact on gaming performance. The first is the GPU (video card processor) and the second is the RAM.

How much RAM do you have?

Have you tried disabling all non essential processes when you play games? I often turn off many startup items before I play.


Collapse -


by superstarpc2486 In reply to The weakest link

I have one gig of ram ddr 800 but my last system had 1 gig of ddr 400 and it worked flawlessly with the same graphics card.

Collapse -

any extra software?

by JamesRL In reply to RAM

Is your system performance setup differently?

Page file?


Collapse -


by superstarpc2486 In reply to any extra software?

what is a page file and how are there different setups.

Collapse -

Go to control Panel, System, Advanced

by JamesRL In reply to Huh?

First look at Advanced/performance/advanced.

Processor scheduling should be set to Programs , as should memory usage.

Virtual memory is below those two; the options are custom, system managed size and no paging file. System managed works best for most people.


Collapse -

Now What

by superstarpc2486 In reply to Go to control Panel, Syst ...

On my XP Media Center PC, everything is fine and looks good. So what do i do if it is still doing the same old games

Collapse -

Other processes

by JamesRL In reply to Now What

Try running msconfig from the "Run" command and look at the non MS apps running, particularly the ones at startup.

Try disabling all the non MS apps and see if that improves your performance.


Related Discussions

Related Forums