General discussion

Locked

Error appears when a compact is performed

By KEVIN.AUSTEN ·
Access 97 (SR-2)
NT4.0 (SR-6)
All service packs installed, as far as I am aware, please see above in brackets.

INFORMATION

A database compact completes OK then suddenly stops working!

The database if fixed using the work around below and then the error below re-occurs after 2 - 3 months, sometimes 3 weeks.

This issue is intermittent and has occurred with different databases in the past, which no longer has issues.

SYMPTOMS

When you attempt to compact or convert a database file (.mdb or .mde), one of the following error messages may appear:

Records(s) cannot be read; no read permissions on database path\name

No read permission on object name

The Jetcomp.exe utility used to compact the file, will generate the same message.

System tables can also appear in the Database window.

CAUSE

This behaviour can occur for either of the following reasons:

Some of the system tables cannot be read or copied. This might be an ownership issue. For example, the tables might be owned by the Jet database engine.
You might not be logged on to the database through the correct user group.
The record source for that form or report is set to an SQL statement that uses WITH OWNERACCESS Option. (The SQL statement creates a hidden query which is delete when a compact is executed but re-created when the form is saved).
You do not have at least Read Data permissions on the table.
The database has been compacted since you last saved the form or report

RESOLUTIONS

All documented solutions have failed to work, which includes:

Making sure Hidden & System Objects are not visible
Checking ownership permissions (making sure <unknown> does not exist and that the system admin has the rights)
Query's are used as the record source instead of SQL Statements were WITH OWNERACCESS exists.
Check Table/Forms etc for correct permissions
All Forms/Reports etc are saved before a compact is performed
Have tried the /decompile option
Make sure two modules do not have the same naming conventions etc
Check missing references (Happens when upgrading from Office 95 to 97)
Tried Jetcomp.exe
Has nothing to do with NT permissions or access rights

WORK AROUND

The current work around is

1) to use the db1.mdb (But if we use the db1.mdb our Oracle ODBC link fails "You do not have the necessary permissions (unknown object)")

or

2) Import the objects into a new database file (Default permissions and start-up options need to be modified).

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Back to Desktop Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums