Question

Locked

Error code 10020 : DCOM on a gaming rig PC, not a Server !

By OldER Mycroft ·
The machine wide Default Launch and Activation security descriptor is
invalid. It contains Access Control Entries with permissions that are
invalid. The requested action was therefore not performed. This
security
permission can be corrected using the Component Services
administrative tool.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.


Unfortunately, M$ H&S doesn't know anything about this error.

From what I can make out, it is a service call for a Server, but I've not got a server - just XP Professional on a gaming rig.

The symptoms are random freezes between 10 and 20 minutes into runtime. The system just freezes solid - no access to Task Manager, nothing at all. Forced shutdown is all that is possible.

Twice now, I've invoked a MESH Computers System Recovery Wizard (akin to the 'clever' system rebuild that you see with Vista) but the 10020 error continues to occur.

Any ideas on how I get rid ??

*EDIT

This 10020 error occurs twice at the end of the boot sequence but brings no calamity with it. However when it happens three or four MORE times, it causes the system to lock up at that point in time.

I found this 'possible' solution searching through Google:
=====================================
Click on Start ... Click on Run...

Type in following command in the text box provided in the Run window.

regsvr32 C:\WINDOWS\system32\wbem\wmidcprv.dll

press Enter ...

Once you receive the confirmation message, follow same steps above to register the second file.

regsvr32 C:\WINDOWS\system32\wbem\wmiprvsd.dll
======================================

But it doesn't seem to have worked as the freezes continue to happen.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Check these settings

by Jacky Howe In reply to Error code 10020 : DCOM o ...

Click Start, Run and type dcomcnfg then press Enter.


Go into Component Services -> Computers -> Right Click My Computer -> Properties -> COM Security tab. Then, under Launch and Activation Permissions, click Edit Default. Check to see that Allow is ticked in all of the boxes under Administrator.

INTERACTIVE should have Local Launch, Local Activation.

SYSTEM is the same as Interactive.

Access Permissions, click Edit Default.

Self both boxes are ticked.

System has only local access.

< Missed a bit >

Collapse -

All present and correct ...

by OldER Mycroft In reply to Check these settings

My settings were identical to those you suggested but since I've forgotten when I did this, you deserve a Thumb 'coz now I've been reminded of the method.

Collapse -

Now you can turn it off :)

by Jacky Howe In reply to All present and correct . ...

as suggested by the good Captain.

Collapse -

Do that and then this...

by CaptBilly1Eye In reply to Error code 10020 : DCOM o ...

One of the first things I do to secure a new rig is to disable DCOM.

In Regedit:
HKEY_LOCAL_MACHINE\Software\Microsoft\OLE registry key has "EnableDCOM" as a named value. By default this value is set to "Y." To disable DCOM, change this value to "N."
Changing this value requires you to restart your computer.


NOTE: for other readers of this thread... this recommendation is for a stand-alone computer not a server and should be done only if you are comfortable with editing the Registry and have a valid back-up of it first.


[edited for disclaimer]

Collapse -

Its not something :)

by Jacky Howe In reply to Do that and then this...

that I have ever botherd with. Until your post I didn't really know what it was for.

Collapse -

During the regedit process I accumulated 14 '10020 DCOMs' ...

by OldER Mycroft In reply to Do that and then this...

After the reboot, now there aren't any. :)

Thanks guys, and if Oh Smeg would care to drop a post into this thread, he also deserves a Thumb for his peermail, coz he beat you both to the post! :) :) :)

Collapse -

Hey, guys !! - It's still locking up !!

by OldER Mycroft In reply to Error code 10020 : DCOM o ...

So now that it's not producing 10020 DCOM errors...

While 'EDGAR' and I were busy handing out the Thumbs, the gaming rig froze again!

Oh Smeg mentioned in his peermail, that online-capable Games can be the cause of this misery, by thinking of themselves as servers.

>>>Breaking News::

The 100020 DCOM errors are back - WHY IS THAT ??

Any further thoughts?

What did I miss ??

Collapse -

You have got a lot of

by Jacky Howe In reply to Hey, guys !! - It's sti ...

crap installed. Have a good look at you HJT Log file. Do you really need all the exras.

If you have recently installed anything remove it. Nvidia seems to run a fair bit as well. There are a lot of Services loaded.

Collapse -

Source of crud is still unknown ...

by OldER Mycroft In reply to You have got a lot of

But I've disabled a shed-load of garbage utilities that must've sneeked onto the system while I was busy racing round the streets of San Francisco sans Karl Malden .

Today the rig has lasted in fits and bursts from about 30 minutes to just over 4 hours without crashing. But it still locks-up from time to time.

I uninstalled GRID as per sensible advice from Oh Smeg, but the freezes keep on coming.

I'm wondering if it may actually be a problem with my Logitech wireless keyboard/mouse combination? Since without input capability, any desktop will look like it has frozen.

Anyway, at present the situation isn't quite as bad as it was before but still annoying for the time being.

*By the way, the Event Viewer bears no witness to any of the lock-ups now, since the DCOM debacle.


< * >

Collapse -

Did you install any

by Jacky Howe In reply to Source of crud is still u ...

software for your keyboard and mouse. If you did uninstall it and let windows pick up the standard drivers on restart.

Back to Networks Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums