General discussion

Locked

Error loading emm386 on IBM Thinkpad a20

By Bentz ·
Here are the specs on the notebook
Thinkpad A20m, 700 mhz PIII, win98se,128 mb Ram,8 GB hard drive, internal cdrom.

I am using a DOS based clipper program and need expanded memory available for the program to run correctly. The following lines are in my config.sys

DOS=HIGH,UMB
DEVICE=HIMEM.SYS
DEVICE=EMM386.EXE

When the emm386.exe attempts to load I get the following error
"EMM386 not installed - unable to set page frame base address"
I have used this app on other thinkpads and had no problem but those had win95 on them.

I have attempted to add numerous parameters to the emm386.exe and had no luck. I found a similar error message on microsoft site but it had to do with a Dell notebook. Not sure if they are related. Ididn't find anything on IBM's site. If anyone has any ideas please let me know. It's worth a lot.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Error loading emm386 on IBM Thinkpad a20

by Parbo In reply to Error loading emm386 on I ...

I have two technet articles for you: Q78557
and Q75592. I'm pretty sure one of these will help you solve the problem. You need to specify what range of memory to use.
Good luck

Collapse -

Error loading emm386 on IBM Thinkpad a20

by Bentz In reply to Error loading emm386 on I ...

I want to thank you very much. After messing around with specifying memory. I was able to include a specific memory area and set the FRAME parameter equal to it. I get a warning message about the option ROM or RAM detected within page frame but emm386 loaded successfully and my app does not crash anymore. Thanks again.

Collapse -

Error loading emm386 on IBM Thinkpad a20

by Bentz In reply to Error loading emm386 on I ...

This question was closed by the author

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums