Question

Locked

Ethernet card not working?

By tardbag135 ·
i just built this brand new computer. it is running WinXP SP2 and is using a Gigabyte GA-EG45M-DS2H motherboard. It has onboard 10/100/1000 gigabit LAN card Realtek RTL8111. but the problem is the LAN card doesnt show up as an installed device in device manager. i installed the driver (thru setup), restarted, but no luck. no matter what i do, it doesnt show up. its enabled in BIOS. if theres anything else i should check, let me know. thank you for your help.

This conversation is currently closed to new comments.

23 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Unknown Devices

by TheChas In reply to Ethernet card not working ...

Look in Device Manager.
Are there any "Unknown Devices" ? Or any devices with yellow "?" or "!" ?

If so, one of those may be the network device. You will need to use the update driver option and point the installation wizard to the folder with the correct driver files.

Next, especially if there are no "?" devices, did you install the full chip-set drivers or just the network driver? Without the full chip-set driver installed, Windows may not even see the network controllers.

Chas

Collapse -

device manager

by tardbag135 In reply to Unknown Devices

no. i installed all drivers and there are no yellow question marks. is the chipset driver the SM bus controller? if so, yes. also i ran the intel INF update utility, which also says chipset drivers. do you think the motherboard is bad?

Collapse -

Anything is possible but it's unlikely

by OH Smeg In reply to device manager

That the M'Board is faulty.

Start off with opening the BIOS and looking under Integrated Peripherals make sure that the On Board HW LAN is Enabled that Smart LAN is Disabled and Green LAN is enabled.

To enter the BIOS you press the Delete Key while the Post Screen or Gigabyte Logo is on the screen.

After checking/changing these settings press the ESC Key and scroll over to Save Settings and Exit press Enter and when the white window appears press enter again confirming that you wish to save the changes. Allow the system to start and look to see if it installs new hardware when Windows Opens.

At this point you Do Not need a Network cable plugged in.

Also did you change any jumper settings before installing the M'Board in the case? If you did return these to where they where as you do not need to change any of these jumpers normally.

Col

Collapse -

Ethernet card

by tardbag135 In reply to Anything is possible but ...

well actually the Smart LAN cant be enabled/disabled -- it more like a diagnostic utility. the Green LAN (when enabled) doesnt help becuz it causes LAN to not show up in Windows. when disabled, works perfectly fine.

I left the jumpers alone. i didnt have any reason to change them. thanks for the help. my PC is back up to top notch! :)

Collapse -

ls is the LAN Enabled in BIOS

by OH Smeg In reply to Ethernet card not working ...

With this M'Board you can disable the LAN Hardware in BIOS.

If that is the case it is turned off and not available for Windows to see.

This may also be useful it is a application that can identify Unknown Devices and unlike Belarc Adviser it doesn't rely on the System Registry to find the hardware it looks directly at the hardware present.

http://tinyurl.com/2zv25t

Col

Collapse -

Questions

by willcomp In reply to Ethernet card not working ...

Did you install motherboard drivers immediately after installing XP?

What, if any, PCI cards are installed?

Here is driver link. Try another driver install after verifying NIC is enabled in BIOS.
http://www.gigabyte.com.tw/Support/Motherboard/Driver_DownloadFile.aspx?FileType=Driver&FileID=2743

I built a PC using the same motherboard about 3 weeks ago. There were no issues with that PC, everything installed smoothly.

Collapse -

PCI cards details...

by tardbag135 In reply to Questions

well i installed an external video card:
http://www.newegg.com/Product/Product.aspx?Item=N82E16814161238

a TV tuner:
http://www.newegg.com/Product/Product.aspx?Item=N82E16815293002

and a WiFi card:
http://www.newegg.com/Product/Product.aspx?Item=N82E16839121008

the ethernet worked the first time i installed XP. now it doesnt recognize at all. if it helps, here is my device manager:
http://www.mediafire.com/imageview.php?quickkey=xzwmro2zom1&thumb=6

yes i did install the drivers once i got onto the desktop for the first time. all of them.

thanks for your help.

Collapse -

IRQ Conflict

by willcomp In reply to PCI cards details...

I suspect an IRQ conflict with one of the PCI cards (assume video card was installed initially). PnP and XP will attempt to share IRQs since there are only a few available after the mandatory ones. A NIC cannot share an IRQ, it must have full use of the interrupt.

Open Device Manager and view devices by connection. See if the NIC and another device are assigned the same IRQ.

To remedy, disable serial ports in BIOS (if possible) and remove PCI cards. Get NIC operable and then add PCI cards one at a time with reboots in between. Determine which card is the culprit. Install cards in different PCI slots when reinstalling. While doing all that, it's possible you may encounter a conflict between a PCI card and the video card.

PnP isn't called plug 'n pray for nothing :)

Collapse -

Yellow Mark

by TheChas In reply to PCI cards details...

Check out the details for that yellow "!" mark next to the PCIexpress bus. Odds are that your ntework adapter is hiding behind that PCI bridge and cannot be enabled until the conflict with the bridge is resolved.

As willcomp stated, it is likely that you have multiple devices attempting to share an IRQ that do not get along with each other.

I would also uninstall and physically remove both the TV Tuner and the WiFi adapter until you get the network card installed. As a general rule, I get all of the motherboard resources working properly before I start on plug-in cards.

Another thought, if you do not plan to use some ports, such as serial parallel and 1394, remove them from device manager and disable them in BIOS setup to free up resources for the rest of the system.

Also, how much RAM is installed? I hope between 2 and 3 GB.

Chas

Collapse -

RAM

by tardbag135 In reply to Yellow Mark

i have 4GB ram installed. i know i need a 64 bit OS, but i have 32 bit for now. XP MCE 2005 SP2. That yellow "!" when i open its properties says not enuf resources. so i will go into the bios and make those changes. right now in bios all parallel and serial ports are disabled. i need 1394 for my DV camera for editing video. ill pull out the unneccsary cards for now until i get this fixed. also one thing to note is that when i go to shut down, the STANDBY button is faded out. In most cases, this means the graphics driver hasnt been loaded. but it has. ive loaded the video driver for onboard and external graphics. maybe that needs more resources too. ill just have to wait and see. thanks for the tip.

Back to Windows Forum
23 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums