General discussion

Locked

Excel formats

By LF King ·
I can't get my spreadsheets to enter a general number or number format as a whole number unless I type a decimal point. e.g. if I enter 1 I get 0.01 If I remove the decimal it rounds to zero. Is there a setting for this or do I need to reinstall?

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
Thread display: Collapse - | Expand +

All Comments

Collapse -

Excel formats

by Krompton In reply to Excel formats

Linda,

It may be a problem with the options settings if you have this problem with all new workbooks. If the problem only happens with one workbook the following may help.
Right click on a cell you are having this problem with. Choose "Format Cells..." and check the setting for that cell on the "Number" tab. Make sure it is "General" or "Number" with the decimal places set to 0.
If this solves the problem and you have only a few cells you need to correct you can select all the cells needing corrected one at a time by depressing the <Ctrl> key as you click each cell then repeat the previous format change.
You can select the entire sheet and make the change, however, be careful as this setting will alter things such as dates. So I recommend you save a seperate copy like Test_YourWorkbookName.xls and make the changes there so you don't lose any information.

Hope this helps.
Krompton

Collapse -

Excel formats

by LF King In reply to Excel formats

Sorry should have been more specific, this happens will all new workbooks.

Collapse -

Excel formats

by Krompton In reply to Excel formats

Linda,

It may be a problem with the options settings if you have this problem with all new workbooks. If the problem only happens with one workbook the following may help.
Right click on a cell you are having this problem with. Choose "Format Cells..." and check the setting for that cell on the "Number" tab. Make sure it is "General" or "Number" with the decimal places set to 0.
If this solves the problem and you have only a few cells you need to correct you can select all the cells needing corrected one at a time by depressing the <Ctrl> key as you click each cell then repeat the previous format change.
You can select the entire sheet and make the change, however, be careful as this setting will alter things such as dates. So I recommend you save a seperate copy like Test_YourWorkbookName.xls and make the changes there so you don't lose any information.

Hope this helps.
Krompton

Collapse -

Excel formats

by LF King In reply to Excel formats

Poster rated this answer

Collapse -

Excel formats

by LF King In reply to Excel formats

I should have been more specific-this happens with all new workbooks. I'm assuming it's coded in the registry, but not sure.

Collapse -

Excel formats

by Krompton In reply to Excel formats

Sorry I missed your comment stating this works with all workbooks. I should have included this in my previous answer but I thought it the more unlikely of the problems.

With Excel open. Click Tools-Options menu. On the "Edit" tab you will probably find the "Fixed Decimal" box checked. Un-check it and save the workbook. This should change the option for this and all new workbooks.

Good luck.

Collapse -

Excel formats

by LF King In reply to Excel formats

Poster rated this answer

Collapse -

Excel formats

by DKlippert In reply to Excel formats

Go to Tools>Options On the Edit tab remove the check mark from Fixed decimal

Collapse -

Excel formats

by LF King In reply to Excel formats

Poster rated this answer

Collapse -

Excel formats

by cricket4b In reply to Excel formats

Check this area when you have formatting problems: Go to Tools menu, Options, Edit tab, uncheck "fixed decimal".
I had this unchecked and my general number category listed whole numbers. When I checked it and entered a number, it had two decimal places no matter what I did to change it.
Hope this helps.
Chris

Back to Software Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums