General discussion

Locked

excel size issue

By naturale02 ·
i have excel book with 2 sheet inside. 1st sheet hav 100+ rows, 2nd sheet hav 12k+ rows. both sheets record are copied frm other excel book month by month. currently it is 4454KB in size, n it is having difficulty to open nor copy record nor save the file. the CPU always surge to 100% and with no responding.
i hav move both sheet to new book, and it is working fine now, any tricks or tips to avoid such scenario happen again as i hav lots of excel book tht are facing the same problem.
many thks

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by BFilmFan In reply to excel size issue

Add more memory to the system handling the spreadsheet.

Or

Move the Excel spreadsheet to a relational database, since that sounds like what you are doing with it.

Collapse -

by sgt_shultz In reply to excel size issue

try office updates?

Collapse -

by chitosunday In reply to excel size issue

If possible , Convert your formulas to values by copy paste special values. Just maintain the formulas in your current sheet.

Collapse -

by CMB from Omaha In reply to excel size issue

Is there any possibility that the spreadsheet is saving to a "lower" version for compatibility with users who don't have Office 2003?

I work in a community college computer lab, and we run into that problem with PowerPoint all the time. The "bloat factor" can be out of this world when saving a presentation in the downward-compatible format.

Collapse -

by karoinaustin In reply to excel size issue

Make sure you are using "Paste Special"-Values (listed under the "Edit" button in the menu) when you place the new values in your spreadsheet.
This will prevent any formulas or macros from the other spreadsheet being copied to your worksheet. That may be why your spreadsheet was bloating.

Collapse -

by DKlippert In reply to excel size issue

Avoid unnecessary formatting. Don't shade a whole row when only 10 columns are relevant.

See <a href="http://www.klippert.com/TCC/Blog/2004/10/excel-spreadsheet-diet-formatting.html">Spreadsheet Diet</a>

Collapse -

by Firedrake In reply to excel size issue

In addition to the above, turn off Auto-Calc. Under Tools/Options/Calulation, select Manual, and check the box to Recalculate Before Save.

Collapse -

by ksimmCFO In reply to excel size issue

I consistently work with excel workbooks (and linked docs) that bloat to 8Meg and upwards (4 years of detailed financial history, charts, trend analysis, etc). So adding memory will certainly speed the update process, but the bigger factor is to apply copy/paste special/values to prior period results that will not be changing. For me, this results in 30% to 40% filesize reduction.

Collapse -

by TonyBaggaDonuts In reply to excel size issue

Your problem may be from too many null cells filling up memory... not just a lack of memory. When I'm working with my reports, this sometimes happens... I'm not sure how or why, but I do know how to fix it.

Do this: in each workbook, scroll to the very last row of data. Select the very first empty row (by clicking the number on the left). Now use the mouse to drag the right-side scroll bar all the way down. It may go all the way down to 65536. Now Shift + Click the last blank row (by the number on the left). You should now have all the blank rows after your data selected by the numbers. Now right click the numbers on the left and choose DELETE from the drop-down list. Repeat for other workbook and SAVE spreadsheet.

Now look at the file size. If you're having the same problem I am it should be much smaller now.

Excel isn't the most durable spreadsheet app in the world and sometimes it hiccups.

Good Luck,
Tony

Collapse -

by AidanMatt In reply to excel size issue

Also check if the workbook isn't a shared workbook. Sometimes workbook size shoots up due to multiple user log.

Back to Software Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums