executables not registering properly

By mr_t_wright ·
Hello all I am trying to figure out what is wrong with this labtop.. For instance when I go to the Microsoft Office folder I dont see the word,access, powerpoint.... just the square that indicates an executable file, same thing in the "my documents" folder. I have tried to right click and make sure that it is being opened with the correct program and it is, however it doesn't show that application that is listed in the "opens with" how can i fix this?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Deleted files?

by TobiF In reply to executables not registeri ...

It looks as if the program files have been deleted, but some parts of the start menu weren't deleted at the same time.

Open Windows Explorer and have a look for the files themselves. A typical place would be C:\Program Files\Microsoft Office

Collapse -


by mr_t_wright In reply to Deleted files?

Hello, no i didnt mean that its not working. I mean the pic that represents the icon is gone. Like for word the icon doesnt show it just says word and has the window that represents and executable file. However in the office folder is shows fine for some reason my desktop and start menu icons arent displaying properly. Instead of showing the icon it shows the executable file icons and for like adobe it shows the icon with the right corner folded down.

Collapse -

Then rebuild the icon cache.

by seanferd In reply to Confusion

Yes, what you wrote earlier certainly misled me.

Which OS? How this works depends on the OS.

Collapse -

Sorry about that

by mr_t_wright In reply to Then rebuild the icon cac ...

I am running Xp Pro

Collapse -

Delete this:

by seanferd In reply to Sorry about that

Documents and Settings\username\Local Settings\Application Data\IconCache.db


(You may have to do this from the Administrator account.)

Collapse -

Wait - you double click an executable?

by seanferd In reply to executables not registeri ...

And nothing happens, but your only recourse is "Open With", despite the fact that executables are, well, self-executing?

Of course, then the documents themselves won't open, nor have the correct icon, either.

If this describes the problem, the registry is corrupted, at least for the EXE extension.

See here, down the page, <i>Executable files</i> and <i>EXE file association</i>: (under <i>E</i>, of course).

If you have XP, you can just use the fix. Later operating systems may have a slightly different registry entry, but you can copy it from a working installation of the same OS.

edited for poor HTML-Fu.

Collapse -


by mr_t_wright In reply to Wait - you double click a ...

Its not all my icons on some of them. Ok, when i go to my "start menu" the word, sprint smart view, and my vpn clinet, quick launch icons dont show correctly. And the same for on my desktop, also it was two pdf files that are on my desktop that used to show the pdf format type but now it doesnt it shows the white icon with the corner dog eared. same as the actual pdf program. However when I click on them they work just fine. I just wont it to look how it should.

Related Discussions

Related Forums