Explorer hangs when WD portable HDD plugged in, help?

By elsenorfon ·
I have a WD 1tb portable hard drive that's been working fine. Suddenly, if I plug it into the USB the computer doesn't recognize that it's there AND freezes windows explorer. As soon as I unplug it, explorer goes back to normal. I can't get to any of my information on the drive, period. I can't format it, I can't do anything with it. I have very important stuff on there that I'd like to save if possible.

Other info:
Safe mode doesn't help.
Windows 7 x64 is what I'm using. I've tried it on three different computers and they all have the same problem.
Periodically it makes a 'ba-dump' sound that the computer usually makes when first plugging in USB if it's left plugged in, even though I'm not plugging/unplugging actively.
As soon as I unplug it, it instantly asks if I want to format the drive. But now it's unplugged so I can't..
Device manager also freezes when I plug it in.
I've tried various recovery softwares/partition programs, none can recognize that the drive's there OR they just freeze.

This is awful, I've done extensive searching and haven't found anything that fully resembles what I have going on here.

Please help!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Couple of possibilities here

by robo_dev In reply to Explorer hangs when WD po ...

Some USB drives are 'right on the edge' of how much power they need to spin up the drive, so a powered USB hub or a USB port on a desktop motherboard will supply more current. You should be able to hear the drive spin-up and initialize when power is applied.

If the drive is dead silent, or if it is going click-click, click-click, click-click, there are other issues as the drive itself is not initializing.

If the drive came with a USB Y-cable, you need to use that. A y-cable is there to provide twice the current, so the drive will spin up.

Similarly, sometimes USB drives have a jack for an external power supply, and that is often needed.

Also try a different USB cable.

If the drive is not properly initializing with proper cables and/or power, then the next steps would be more invasive. The hard drive inside the WD-labeled USB enclosure is just a standard WD hard drive.

If the electronics of the enclosure have failed or perhaps the USB port is damaged, that drive can be removed from the enclosure and either installed in a different enclosure, or installed in a desktop PC.

If the drive does not initialize when plugged into a PC directly, then, unfortunately, we must transition from a rescue to a recovery operation. First try the other things, then re-post your question if nothing else works.

Related Discussions

Related Forums