Question

Locked

explorer.exe won't load

By d1g1t ·
Hello World:

I am a first time caller, long time listner, running 32-bit Windows XP SP3 on an AMD Sempron 3400+. (Don't laugh) Explorer won't load. The symptoms are thus:

I recently un-installed an old UBISoft game called Splinter Cell Chaos Theory and then restarted my computer. On the way down I heard the familiar sound that windows always makes however, on the way up, there was no sound. I rebooted the computer a couple of times and sure enough, the Creative X-Fi card would only produce sound as Windows was signing off. I re-installed the sound drivers from cd and rebooted but when I clicked on various music apps they all said something to the effect that there was a certain file/object that could not be located.

I rebooted again after reinstalling drivers and I actually heard that opening startup windows sound but was not prepared for what came next.

I have no icons, system tray, start menu or quick launch bar. Just nothing but wall paper and no icons.

I hit ctrl-shift-esc to bring up task mangler and explorer is not on the list. While I had taskman running though, I noticed only about 32 out of 48 tasks running. I brought down the taskman menu to run the command line type of stuff like explorer.exe and cmd and sfc /scannow but it's not having any of it. Taskman just blinks out of site. I can bring it back no problem but it won't let me enter commands through it.

I also can use the winkey-u command and it works. And of course the sound works.

So, I rebooted to safe mode with command prompt and tried to run sfc /scannow and it says RPC server unavailble. I thought maybe a digital certificate might be preventing explorer from loading (based on a quick google search and a trip to microsoft) so I ran mmc and added the certificate snapin and checked out the trusted root cert called NO LIABILITY ACCEPTED and its there. It shows that it's been expired since 2004 but I checked a few other computers and they all look the same except of course they work.

So, after running chkdsk /r and seeing that yes, a few files did get moved around (but I couldn't tell which ones) I rebooted and the situation was unchanged.

So, I did an XP repair type of install (twice now), all to no avail. The memory and mobo check out. Video card is fine. Even with limited options, I was still able to run Eusing Free Registery Cleaner and the there doesn't really seem to be any problems with the registery. It looked pretty clean. I reinstalled explorer.exe in both places \Windows\system32 and \Windows\system32\dllcache\ and file sizes match at 1,000,960 bytes which is what they were before.

For some reason, I don't seem to have any restore points. The only thing I can think of is that something software related is keeping explorer from loading.

The only other symptom I can think of is that the system tray was acting up once in awhile by not showing all the icons that should be running however, all the icons were showing prior to my reboot while messing with the Creative Labs install disk. I still have sound though, no problem their. A clean install is not an option.

Please help.

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

See if this is of any help

by Jacky Howe In reply to explorer.exe won't load

No Desktop or Blank Desktop After Logging On to Windows

http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q256194


SYMPTOMS
When you log on to Windows 2000, you may see a blank desktop or no desktop. When this occurs, you can press CTRL+ALT+DELETE to start Task Manager, but Explorer.exe is not listed in the list of running tasks or processes. Starting a new instance of Explorer.exe does not resolve the issue.

RESOLUTION
To resolve this issue: 1. Press CTRL+ALT+DELETE, and then click Task Manager.
2. On the File menu, click New Task (Run).
3. Type cmd.exe, and then press ENTER.
4. If necessary, change to the %SystemRoot% folder.
5. Rename the Shdocvw.dll file by typing ren shdocvw.dll shdocvw.old.
6. Restart the computer.

CAUSE
This issue can occur if there is an older version of the Shdocvw.dll file in the %SystemRoot% folder. Because Explorer.exe is located in the %SystemRoot% folder, the search path for any called files starts in the %SystemRoot% folder before the path is searched. The default search order always looks for a called file in the folder containing the program file before searching the path to locate the file.

Collapse -

...hmmmm

by d1g1t In reply to See if this is of any hel ...

Shdocvw.dll exists in the same two directories on my system as explorer.exe (see above) I renamed them to .old then rebooted. explorer.exe loads while the welcome screen is up and, it is at that point that explorer.exe now complains about not being able to find shdocvw.dll.

So, I rebooted back into safe mode with command prompt and expanded shdocvw.dl_ out to the two directories where it used to be, (from the i386 directory on my XP cd).

After rebooting Windows, with the welcome screen showing, (this is *after* logging in) explorer.exe still complains about not being able to find shdocvw.dll.

It's way past my bedtime. I surrender, but don't the rest of you give up. ;-)

Collapse -

Try this

by Jacky Howe In reply to ...hmmmm

Have you Registered the .DLL files, if not run this.
Copy and paste the lines below into Notepad and save it to the Desktop as load.bat
Double left click on it and it will re-register all of your .DLL files.
---------------------------------------
C:
cd %windir%\system32
for %%s in (*.dll) do regsvr32 /s %%s

---------------------------------------

Collapse -

...hmm ...hmmm ...hmmm

by d1g1t In reply to Try this

I created two batch files. One runs against the .dll's in windows\system32 and the other runs against the files in windows\system32\dllcache and the batch files are based strictly on what you have suggested above.

So, here's what happened.

Even though I am running from the safe mode command prompt window, Visual Studio Just in Time Debugger kicks in. Not right away though. Not until BORLNDMM.dll shows up on the screen. I would guess that as the batch file runs it only displays files after they have been processed though.

Anyway, Visual Studio says that an "Unhandled win32 exception error ocurred in regsvr32.exe [1016]" and wants to know if I want to start using it as my default debugger and I say "No". Then as files continued to fly by on the screen, I scrolled up to the file that comes just after BORLNDMM.dll and next in line is browselc.dll. I also get error codes of [364] and [184 from Visual Studio. I don't know if that's helpful, but why is regsvr32.exe having a problem with that file?

The next item that crops up is that there are different incompatible files for the Nvidia card and it says that openGL is disabled to maintain compatibility. Don't ask me how ver 174.whatever can install ontop of 169.xx? and leave all those files out their, or even when it happened. The system was stable even with incompatible .dlls in the windows/system32 dir. They were not found in the windows/system32/dllcache dir though.

Now the sound card symptom is starting to make sense, obviously. But now the question is, how do I dig out from under it all.

Also, when I run the batch file against windows/system32/dllcache this is what I get:

"LCPTR.TBL" and then I get sixteen square symbols right after that. The file on screen at the time is uniime.dll. The file that comes right after that is unimdmat.dll.

At any rate, It all leaves me right back where I started. I have tons of work to do but explorer.exe will not load.

Collapse -

Try this

by Jacky Howe In reply to Try this

Boot into Safe Mode Command prompt. Logon and at the Prompt type in regsvr32 %windir%\system32\shdocvw.dll
Press OK when it is loaded.
Let us know how you get on.

< spelling and missed a bit >

Collapse -

here we go again

by d1g1t In reply to Try this

I just did a repair type of install again after ripping out all the nvidia files and directories. XP asked for the Nvidia nforce disk and for the nvidia driver disk before the install was over. This was encouraging but the end result was the same.

So, I ran my batch files again and I still get the LCPTR.TBL error when regsvr32.exe hits uniime.dll and I still get "Nvidia different incompatible files openGL disabled to maintain compatiblity" error message, AGAIN!

So anyway, after all that I have done as you asked, and ran regsvr32 against shdocvw.dll and hit O.K. and regsvr32 was successful, and because I scheduled chkdsk /f to run on boot since chkdsk won't run that switch any other way, this may take awhile, so I'll get back to you .... and just checked. I am done.

Now I don't even get wall paper. just a gray screen. Task mangler still works and the sound is working just fine.

If the video is causing the problem, then maybe I should pull out the Nvidia PNY 7600GS AGP card and stick in my old ATI 9660? and see if that works?

Collapse -

See how you go with this

by Jacky Howe In reply to here we go again

Go to the Nvidia site and download the Latest NVidia Drivers.

Resart the PC in Safe Mode. Navigate to Device Manager and uninstall the Video Driver. Navigate to C:\WINDOWS\system32\drivers and delete this file "nv4_mini.sys"

You should be able to start normally, if not restart in Safe Mode and install the new drivers.

Collapse -

Not very well I'm afraid

by d1g1t In reply to See how you go with this

explorer.exe does not load in safe mode either.

My only environment is the DOS> Prompt. Dir nv*.sys shows that their are no files by that name in either windows\system32 or windows\system32\dllcache.

I've googled this issue and found no one who has successfully recovered from this without wiping the hard drive and starting over.

I am going to swap video cards and re-install XP with the recovery/repair option and see what happens. After that, I may put linux on the same machine and see what I can get out of it, but before I do, my next question will probably be something like, "How do I recover/move all of my programs like Office2007. Getting the data off shouldn't be too tough. Getting all my programs back is another story all together. I downloaded (paid for) Microsoft Office2007 through their "Ultimate Steel" student program. Now, If I start fresh, that's another 300 Meg on top of all those service packs and shareware, not to mention reconfiguring my personal settings and going through all the updates for all the programs just to be current again.

Didn't there used to be programs that let you move programs around from one drive to the next? while updating the registry so Windows could find/see them again?

Anyway, I have no access to the device manager or control panel so I am going to swap video cards. Nothing else has worked.

Collapse -

If the desktop is still missing/corrupted ...

by OldER Mycroft In reply to explorer.exe won't load

You might have difficulty saving a batch file to it.

So, click on Start > Run and in the command line box, type:
regsvr32 /i shell32.dll

Usually when the Task Manager & the Desktop are misbehaving, the Shell tends to play up too.


<Extremely silly typo!>

Collapse -

...hmmmm

by d1g1t In reply to If the desktop is still m ...

The only way I have of getting anything done on my pc right now is to boot in to safe mode with command prompt. I get no shell in safe mode either however, it does load cmd.exe and I have access to my XP cd in drive E:

So, I ran regsvr32 /i shell32.dll per your suggestion and this is what came back from the void:

"dllinstall in shell32.dll failed. Return code was: 0xc06d007c"

I don't seem to have any problem running regsvr32 without the switch /i though.

Of course explorer.exe still won't load.

Back to Networks Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums