Question

Locked

External HDD fine but unreadable on laptop

By save ·
I have a 300 GB Ext HDD connecting via USB. On my desktop the HDD works fine. All files are accessable and there is absolutely no loss of data.

When plugged into my laptop the drive appears in the my computer screen (XP home with SP2 on an Acer laptop)but when I attempt to access the drive the laptop says the drive needs to be formatted. The properties indicate there is no data although the desktop says there is.

There has to be something in the Laptop causing this. The computer did recently have an issue not finding an IP address and a computer tech guys fixed that issue and said my external HDD would have to be formatted but I think he may be just a little dull.

Anyways, the laptop works fine with all peripherals working fine in device manager. Recently did a firmware update on the wifi and the intel chip to try and fix the problem but as yet no solution.

I have an external HDD in fine working order but can not access it. Do you guys have any suggestions other than a complete reformat of the C and/or D drives of the laptop or the external HDD? I have previously has this running fine for over 18 months to the laptop so it must have something to do with the recent trojan I removed.

Have up to date AVG, Spybot, and adware all recently updated and run.

This conversation is currently closed to new comments.

26 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

NTFS Filesystem.

by normhaga In reply to External HDD fine but unr ...

You failed to mention the OS you are using on your desktop. If it is Vista, then try updating the laptops NTFS to 5.1 and add the current updates.

Also, look to see if you have assigned the external disk a drive letter on the laptop before the above.

Collapse -

A couple of things to try

by Jacky Howe In reply to External HDD fine but unr ...

Reconnect the Drive to your desktop PC and Click on Start, Run and type in cmd and press Enter.

At the command prompt type in chkdsk volume:/r and press Enter.

If it finds any problems it should correct them. When it has finished try it in the Notebook.

If there is no sucess from that try this on the Notebook.

Go into "Control Panel"
Open "System"
Click the "Hardware" tab
Click "Device Manager"
Expand Universal Serial Bus controllers section.
Right-click every device under the Universal Serial Bus controllers and then click Uninstall to remove them one at a time.
Restart the PC, and allow the computer to reinstall the USB
controllers.
Plug in the removable USB storage device, and then test to make sure
that the issue is resolved

A Powerd USB Hub could also be tried.


You can use the Hard Drive Makers Testing Utility to Test the Drive

Hitachi / IBM - DFT "Drive Fitness Test"
http://www.hgst.com/hdd/support/download.htm
Works with all manufacturers

Western Digital "Data Lifeguard"
http://support.wdc.com/download/index.asp#dlgtools
Works with WD drives only


Fujitsu "FJDT"
http://www.fel.fujitsu.com/home/drivers.asp?L=en&CID=1
Works with fujitsu models only

Samsung "hutil"
http://www.samsung.com/Products/Hard...ties/hutil.htm
Compatability unknown...

Seagate "Seatools"
http://www.seagate.com/support/seatools
Works with Seagate drives only

Let us know how you get on.

Collapse -

Many thanks for the excellent post, True Blue

by nepenthe0 In reply to A couple of things to try

This post is an excellent resource, which I have carefully archived for future reference. If I ever have occasion to respond to a similar query in this Forum, True Blue will be cited as the authentic source.

Appreciatively,

Rick/Portland, OR

Collapse -

Now tried those suggestions.

by save In reply to A couple of things to try

Typed in on desktop:
cmd
chkdsk volume:/r
The drive, path, or filename are not valid.
Tried the same but with h instead of r and got a different error message (not valid or something).

Unistalled USBs and restarted laptop but still the same.

On the desktop went to properties of H drive, tools, check disk options, auto fix file. Went through three phases but no difference.

External HDD still works fine on desktop but not laptop. Laptop is the main computer. Desktop is old and an emergency back up which is kept up to date.

Under properties found the following:

NTFS file system
No volumes
Name is: ST332062 0A USB device

Collapse -

Found some extra information

by save In reply to A couple of things to try

Found the following in device manager USB mass storage device details. I do not remember seeing this before.

Device Instance lds

USB\VID_067B&PID_2507\13


Given my recent troubles with the laptop not finding IP addresses (now fixed) I can not help but think this may be part of the problem.

Collapse -

If you where to tell us the Make & Model

by OH Smeg In reply to External HDD fine but unr ...

Of the external Drive it would helpful. If it is a Powered Device with it's own Power Pack you need to look at the Partition Type and alter as required.

If it is a Unpowered type you need a Powered USB Hub or if it has 2 USB Plugs on the end of the USB Cable where it plugs into the NB you need both of these plugged into the NB not a Hub or other adapter. The reason here is that modern NB do not have a lot of power available at the USB Sockets so external HDD's need to get their power elsewhere. A powered USB Hub will provide 500 MA for each USB Port and allow the drive to run correctly. The NB can not supply this much Power at it's USB Ports.

Alternatively you could plug it into your Desktop and Network the NB to the Desktop and transfer data to the external Drive from the NB that way. But you should tell us what you have running here for directions on how to do this. Knowing that there is XP home on 1 computer isn't enough information.

Col

Collapse -

Answers so far...

by save In reply to External HDD fine but unr ...

OS on both desktop and laptop started as 98SE, thence XP home and then SP1 in that order prior to anything else going on.

Desktop is the Frankenstein's monster of desktops with a little bit of this and that scavenged from discarded computers.

The drive consistantly comes up with H drive. I have renamed the drive "300GB HDD" on the laptop and this still shows up on the desktop but not the laptop. Only H drive.

I have yet to try everthing on ? couple of things to try". WIll let you know within a day or two once done.

The HDD drive is a single USB type with external power. Make and model is a mystery as it's an eBay one the wife got me.

I realise I need more information and will attempt to power up the desktop monster tonight and get some answers.

Collapse -

Reponse To Answer

by Darr247 In reply to Answers so far...

ST332062 is a seagate SATA drive, for what it's worth.

If you google just ''0A USB Device'' you might not be surprised to find the model numbers in the results appear to all be seagate.

I guess I'm going to have to break down and remove the drive I'm trying to access with jellybean from the mini tower and mount it in another computer that will boot, and access it from the IDE channel, not with a USB adapter... none of the answers I've found about this problem have helped an iota.
It shows up in the Disk Management snap-in (without a drive letter), but the 'Change Drive Letter and Paths' option is greyed out (the only option NOT greyed out for that drive is Delete, and I don't really want to delete that partition yet).
All its files show up fine automounting on a linux box with the USB adapter, but I don't find a linux equivalent to jellybean.

Collapse -

File type may be the issue.

by save In reply to External HDD fine but unr ...

The desktop reads the HDD fine and reads it as NTFS. However, the laptop thinks it is a RAW format and then wants to reformat. Could this be the issue?

Collapse -

OK as this is a Powered External Drive

by OH Smeg In reply to File type may be the issu ...

The only solution available to you is to copy all the data on the external drive that you need to the Desktop and then plug into the NB and format from the Drive Manager.

Vista can not open Partitions that where made on a system older than it was designed for. So a lot of Drives formatted with older versions of XP will not open under Vista. You have to format the drive on the Vista computer to make it available to Vista's improved Security.

Nothing else available here I'm afraid. But if you network the Desktop to the NB you will be able to copy the files to the NB from the Desktop and then format the drive on the NB.

Col

Back to Hardware Forum
26 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums