General discussion

Failed to start mysql.service

By wolvering247 ·
Hi, there.
I followed your tutorial here but then got stuck during the execution with the line

https://www.techrepublic.com/article/how-to-set-up-mysql-for-remote-access-on-ubuntu-server-16-04/

systemctl restart mysql.service

It returns me this error.

I did try to find solutions in other discussion but none fixed my problem.
3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

what's the error posted?

by Jack Wallen Tech expert In reply to Failed to start mysql.ser ...

I didn't see an error in your comment. You might also try to restart with the command:

sudo systemctl restart mysqld

That should do the trick.

Collapse -

Failed to start mysql.service

by hostechs1 In reply to Failed to start mysql.ser ...

Checking MySQL logs can provide you the more relevant info.

Collapse -

shall work

by snicolas68 In reply to Failed to start mysql.ser ...

sudo systemctl enable mysql.service
sudo systemctl start mysql.service

Then, you'll need to secure the installation as mysql is providing a command line tool where you will be, or shall (depends of the release) be prompted to allow or not remote connections.

Your firewall could be an issue.
You too need to create a separate user and grant to that user with rights to avoid using root to operate...

for logs:
journalctl -xe

The article is about enabling remote access to mysql, not about installing it and setting it up. Did you even installed it?

Look for an article explaining how to properly install mysql before jumping to tweaking it. Step by step.

Back to Linux Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums