File and Printer Sharing Problems with Netgear WNR834Bv2 Wireless-N Router

By Chrisbat ·
Okay I'm posting a thread about this issue because I've
been looking all over google for a solution to this problem
and I can't find one relevant page. As such I've been
dealing with the Netgear support staff for a week and they
haven't been much help either, so I'll lay out the problem
that I'm having with this ?new amazing router" that
NetGear just released and see if anyone on here has any

So I'm setting up a new Wireless-N router for a client of
mine who's always had range problems with their old
Wireless-G network. Up until now they always had a
Linksys WRT54Gv2 router which, despite its limited range,
never gave them ANY problems. All the computers in
their home network could always communicate with each
other and all the shared printers on the various computers
were accessible to all even with all the computers having
their firewalls turned on.

So I install the new Netgear WNR834Bv2 Wireless-N router
in place of the old Linksys one and everything seems to be
going good? great signal, I can access the internet on all
the computers right out of the box, BEAUTIFUL!

? but wait? Why can?t any of the computers print
anymore? Oh they?re not visible to each other anymore?
and why are all the computers no longer visible to each
other anymore? Well that?s the 25,000 dollar question
that I?ve been spending the past two weeks trying to
figure out.

I won?t tell you the 45 steps I?ve gone through up until
now to figure out what I have so far, but here?s the
relevant information? When I completely disable the
Windows Firewall on all the computers, suddenly
everything works fine. But when I turn on the firewall with
the ?File and Printer Sharing? firewall exception enabled in
the Advanced menu, the old Linksys router communicates
fine through that but the new Netgear one doesn?t.

What gives? It?s almost like each computer is sending a
signal to one port on the Netgear router and the router is
now either sending it to another port or doing something
screwy with it that makes the other computers think it?s
not a File and Printer Sharing related signal and they in-
turn ignore it.

As a side note, I could always ping the other machines
running the Linksys router through the command prompt
even with the firewalls enabled, but now I can?t ping the
other machines through the NetGear router unless all the
firewalls are completely disabled.

Anyway, that?s my issue. Does anyone know what could
be causing that or what I would need to do to create a
new exception in the windows firewall in order to listen to
the correct NetGear File and Printer Sharing port since it
no longer matches the Windows default port for File and
Printer Sharing?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Issues with Netgeat WNR854t

by adamentity In reply to File and Printer Sharing ...

I have also had problems with the new routers. You think when you buy the latest device off the shelf it would be caught up with current technology.

I found correcting the problem (after exhausting troubleshooting) took a Firmware update to the latest 1.4.23NA. Let me note that the automatic update built into the router never showed an update available.

Hope this gives you a few more options to try.

Collapse -

Solutions (But still problems)

by Chrisbat In reply to Issues with Netgeat WNR85 ...

Hi Adam,

Thanks for the reply! I actually haven't updated this
thread since I originally posted my problem. After about
15 more emails back and forth with Netgear, they finally
sent me that firmware update you're referring to, which
fixed the Windows firewall problem... But I realized (after
the fact) that both MacAfee and Norton 360, both still
block the Netgear signal but not the Linksys signal.

So in other words, when the only firewall turned on is the
Windows firewall, that firmware update has fixed it so all
the computers can talk to each other and see each other.

But the moment that any standard security software is
enabled (like Norton or MacAfee using their ?default
settings?), suddenly nothing can see each other again.
*slaps forehead*

I don?t really understand why the Linksys router worked
fine and the Netgear one is giving me migraines (and I get
the feeling that tech support doesn?t know either). The
BEST part is how every time I talk to tech support, I get a
new person, and they always start the conversation off
with "ahh, there must be a problem with your firewall
settings." I just want to shout, "Nooo, there's a problem
with YOUUUUR ROUTER since your competitors product
worked fine."

I mean it?s not like they won?t make their money back if
they plug it in to a computer first to make sure it works
just as well as their old products. I would think that
would be a fundamental step they take before distributing
it, but apparently they just wait for everyone to complain
before they fix things? great business model.

Eye yey yey =/

Collapse -

I have a fix for yea

by win7man In reply to Solutions (But still prob ...

I know it;s been 2 years, but trying enabling open NAT and enabling UPnP. That should fix it

Collapse -

Did you find a solution to Printer Sharing Problem?

by allencblake In reply to File and Printer Sharing ...

I am having the same problem with a netgear DGN2000 wireless plus ethernet router with DSL modem. Did you find a solution to your problem?

Collapse -

The Fix

by win7man In reply to Did you find a solution t ...

I have a fix u just like the other guy. Enable Open NAT Settings, and Enable UPnP In your router.

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums