General discussion

Locked

File explorer hangs on locked processes

By jbuzz ·
Windows XP file explorer locks multiple processes and stops responding when trying to delete files.

This has been on ongoing problem for me with XP since its first installation. I have tried every obvious solution that I am aware of with no success.
1. Safe mode.
2. Changing msconfig for selective startup.
3. Uninstallation of unneeded applications.
4. Disabling services that are using network resources.
5. Disabling firewall and anti-virus processes.
6. All system components are fully updated.
7. Full system wipe and OS re-install.

This happens on three different systems running XP Pro SP2 so I am confident this is not hardware related.

Windows explorer.exe locks files and I am unable to modify them without stopping explorer.exe at the Task Manager and using the command line to make file changes. This is hideously inefficient. I am using freeware app WhoLockMe.exe to see that it is always Explorer.exe that has locked one (or more) processes on the files. Frequently this happens to a single file in a directory containing multiple files. It may have as many as 5 PID's locked by explorer.exe.

This conversation is currently closed to new comments.

17 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by BFilmFan In reply to File explorer hangs on lo ...

Sounds like you have tried everything, but let's see here.

When you did the full OS wipe, did you remove all partitions and do a reformat of the disk?

Have you tried installing a new Windows OS by itself in a new partition and directory with no other software loaded?

You said this has occurred on 3 different systems. Are these systems networked and has that network been scanned for a worm, virus or trojan coming from a server, such as FunLove or one of the other NETBios-capable ones?

As an additional question, are the 3 different systems the same hardware aka all the same vendor and model?

Does the issue happen with just SP1 on the system?

Collapse -

by jbuzz In reply to

I have added comments to provide additional details

Collapse -

by Toivo Talikka In reply to File explorer hangs on lo ...

That sounds really strange if it happens on three different PCs. Have you scanned the systems for spyware, using an anti spyware application?

I'd use Spybot Search & Destroy, or check the list of reputable anti spyware scanners from http://www.spywarewarrior.com/rogue_anti-spyware.htm#trustworthy.

Collapse -

by jbuzz In reply to

Individual systems and network traffic is monitored for mailicious apps. I use Spybot S&D, along with several other tools, but find it returns too many false positives. It falsely identifies several required graphics and print related processes as trojans.

Collapse -

by jbuzz In reply to File explorer hangs on lo ...

***Additional details***

Network: Yes, all affected machines are on the same IP network. Other mahcines on the network are not affected.

Hardware: one Dell laptop - P4, 1.0GB, 2 partitions
two custom built PC towers with multiple physical drives.

Partitions: No, I have not completely wiped the drives to remove partitions. Data is stored on the non-boot partitions.

Viruses: I have scanned the machines and network for all types of malicious processes. Nothing found. Additionally, I see no evidence of Trojan activity in outgoing firewall logs.

Collapse -

by jtakiwi In reply to File explorer hangs on lo ...

Check the switch, try resetting and see if it helps. Also, it could be a name resolution issue, make sure DNS or WINS is operating properly. Check the binding order of the NIC(s) on your server, make sure it is right for your environment.

Is the problem when you initially browse to the file, or after you open it? If the latter, ensure that firewall on pc's (or server) isn't blocking traffic (I know, sounds stupid, but I had a pc that I turned off the firewall, but all the rules stayed, intermittently).

Collapse -

by jbuzz In reply to

The trouble is strictly local to each machine. I am not trying to work across the network using explorer.exe. Local files are locked by instances of Explorer.exe processes on each machine.

I am not using WINS on these machines. LMHOST files direct name resolution to static print servers for some machines and central DHCP provides addressing for all.

The only change I have made to network binding is to move WebClient service to the bottom of the provider list.

There are definitely problems with network connectivity related to explorer.exe, but I don't think they are related to the file locking issue. Removeable storage (USB drives) still appear in the Network Neighborhood after the devices have been removed, causing Explorer.exe to stop responding when trying to browse the Network Neighborhood.

As far as the firewalls go, I have uninstalled local soft firewalls and disconnected the hardware firewall and still had this file locking issue.

Collapse -

by sgt_shultz In reply to File explorer hangs on lo ...

...when trying to delete files...
where are the files? local? network? both? are you on a domain or workgroup is time synched?

Collapse -

by jbuzz In reply to

local only (see above)

Collapse -

by BFilmFan In reply to File explorer hangs on lo ...

Does the issue exist when you have just SP1?

You can delete just the OS partition and leave the data ones alone.

Back to Windows Forum
17 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums