Question

Locked

Files corrupted on USB thumb drive???

By dkulmacz ·
I recently purchased two 4GB USB thumb drives to use for MP3 storage. They are both formatted as FAT32 (the only option I seem to have).

When I try to copy MP3 files onto the drives, all works well until I move about 900MB of data. After that, any new files I transfer are corrupt . . . I can't play them, or delete them, and if I remove the drive and replace it I see odd files and directories on the drive. This happens with both drives, and I've reformatted both many times, scanned for errors, etc.

My HD is formatted as a NTFS drive. I've tried reformatting the USB drives as either FAT or NTFS using various utilities, but get errors when I try this.

This is driving me crazy . . . any suggestions???

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

for starters... curious...

by CaptBilly1Eye In reply to Files corrupted on USB th ...

Have you tried using a different computer to plug either of the sticks into to then transfer files?
What brand are the sticks?
The sticks I have are all using regular FAT rather than FAT32 and I know NTFS often won't work.

Collapse -

a possibility

by normhaga In reply to Files corrupted on USB th ...

You may need to have several different directories from the root directory. If I recall correctly, FAT only allows 512 root entries.

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums