Question

  • Creator
    Topic
  • #2149644

    Flash drive not visible

    Locked

    by lidiajanusz ·

    When a new flash drive is connected to the PC it recognizes it but it can not be found in Windows Explorer. It is present though in Disk Management. If automatically assigned drive letter is replaced with “G” then it shows up in Windows Explorer. What setting should I change to allow automatic assignment of a drive letter without side effects? I suspect it’s limited just to “G”.

All Answers

  • Author
    Replies
    • #2913521

      Clarifications

      by lidiajanusz ·

      In reply to Flash drive not visible

      Clarifications

    • #2913506

      Write down all fixed Disk and CD/DVD drive letters so as not to delete them

      by rob miners ·

      In reply to Flash drive not visible

      This should give you a fresh start with drive allocation letters.

      1. Login with Administrative privileges.

      2. Disconnect all USB or FireWire storage devices.

      3. Open Registry Editor and navigate to the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

      4. Under HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices there will be registry keys with the name that resembles the format of \DosDevice\X: where X can be any alphabet letter which corresponding to your physical system drive letter.

      5. Delete all possible USB drives, FireWire drives and external drives which have a drive letter.

      DO NOT delete any of the fixed Hard Disk Drives or CD/DVD optical drives registry values.

      Exclude \DosDevice\A: which normally reserved for floppy disk drives.

      Backup the Registry before making changes

      < add a bit >

Viewing 1 reply thread