Question

Locked

Flash drive not working in USB 2.0 ports

By stormont ·
I have a USB 2.0 flash drive I've been using since last spring. Starting just the other day, I can't get USB 2.0 ports to recognize the device on any computer. It just pops up a "Device Not Recognized" bubble from the taskbar. The device still works fine in USB 1.1 ports.

This is a problem I've had with every computer I've checked it on (about a dozen computers at school as well as the two I have at home) and it just started a few days ago.

The device is a 2.0 device; when I plug it into a 1.1 port, it gives me the notification that it would be faster to put it in a 2.0 port. There is also no dirt or signs of damage on the device or the contacts.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

IMHO

by garytro In reply to Flash drive not working i ...

sounds like the drive has gone bad. Wish I had more information for you.

Collapse -

I have the same problem

by spethg In reply to IMHO

Starting around 2/7/07 as far as I know (I don't use it every day) my flash drive started doing the exact same thing. At first I thought my work computer was just messed up, but I tried it on 6 computers total and every time USB1.1 worked and USB2.0 did not. In my device manager it lists the drive as "Unknown Device". LOL to use it I plugged it into an old laptop and shared it over the network :-p I'll let you know if I figure out what's going on.

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums