General discussion

Locked

floppy drive not working

By ewilliams ·
every time i put a floppy in the drive it says the floppy is not formatted. i've tried to switch out the cable and the drive, but the samething happens.
i'm wondering if the controller on the motherboard is bad or is it a problem with windows2000. can someone please help me i never ran into yhis problem before!!!!!!!!

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Black Panther In reply to floppy drive not workin ...

Are you using pre-formatted floppies? Does the same floppy work in another floppy drive?

It's also possible that the floppy drive itself may need to be replaced?

Swap the floppy drive with another floppy drive working on Windows 2000

Collapse -

by ITgirli In reply to floppy drive not workin ...

is it a clean floppy, or something you are trying to get data from? I had the same problem when I tried to get data from a floppy that had been used with a different Windows version. Microsoft is not often compatible with itself.

Collapse -

by RCOM In reply to floppy drive not workin ...

You might try reinstalling the motherboard drivers.

Collapse -

by OTL In reply to floppy drive not workin ...

Tried;

1. Cleaning the floppy drive ?

2. Answer above reloading the drivers ?

3. Replacing the floppy drive ? Heads can get misaligned through use.

4. Formating a blank/new floppy on the drive and see if it still wants to reformat ? (This would indicate the read heads are misaligned and drive needs to be replaced)

5. Verified cables are correctly/fully seated ? (OOPs see that you replaced the cables)

6. Put it in another system to see if it works there ?

If it was a motherboard controller problem you would normally not be able to "see" the floppy drive in my computer, although it could be a data output problem from the FD.

Collapse -

by Bull173312 In reply to floppy drive not workin ...

There is a program called Check-It that will test your system. You might want to try it. Since you have replaced everything else it sounds like it might be the controller.

Back to Desktop Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums