General discussion

Locked

Floppy Drives

By arkain_113 ·
Hi, well i have a question about floppy drives. you see i have a floppy drive that keeps reading the samething even if you put in another disk in the unit. cause it will only read the first disk you have inserted until you have restarted you computer. and i don't know what to do. i tried to refresh the window and it didn't work. i have tried so scan for virus or spyware on the system and it still the same problem. is there another way of fixing this with out buying a new floppy drive?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ghimpe-- In reply to Floppy Drives

This isn't much help but you shouldn't buy a new floppy because this sounds like a software problem not a hardware one.

I had never encountered something like these so i can't realy give you a solution. Maybe answearing some question will help us help you:

Is these behaviour recently?? Did the floppy driver ever worked like it's suposed too?
What OS are you using??
You say the floppy will show the contenent of the first disk inserted even if you replace the disk. Is the contenent of the drive also accesable even if you replace the disk?? (aka is the OS making a virtual disk of your floppy)

If this is a new problem you could try doing a restore of the OS to a previous date when the floppy worked OK.

Collapse -

by ep_turo In reply to Floppy Drives

please change your floppy drive

Collapse -

by HAL 9000 Moderator In reply to Floppy Drives

Well provided it did work once I would tend to think it is a software problem rather than a hardware problem. If you can answer a couple of questions we just might be able to help you out but I've never ever heard of something like this happening previously so I'm as baffled as you are.

Firstly what OS are you running and what level of patching has been done?

Did it ever work properly?

If it worked what was done to the computer just prior to the floppy displaying this behavior? Did you change some hardware install new drivers or software?

What is on the floppies and does this still happen with a Windows Boot Disk inserted? Like will it boot and then execute something from a different floppy while in DOS Mode?

If the answer to the last question is YES you defiantly have a software problem as the floppy is working properly but when the OS gets loaded it stops working properly.

Have you looked in the BIOS to make sure that it isn't set to some strange value?

Did you flash the BIOS recently? And if you did, did you follow the makers directions?

If nothing else lets know how you get on as this has me interested.

Col

Collapse -

by grbeckmeyer In reply to Floppy Drives

It may be the controller, not the floppy drive. I saw something similar about 3-4 years ago...booted to DOS for troubleshooting, do a DIR, then change the floppy, do another DIR and it displayed the same results. On top of that, it would write that directory onto the 2nd disk, making it useless until reformatted. Same thing happened with another floppy drive. It was an old spare system, so I didn't mess with trying to install a new controller. Could only have been a virus if it had somehow infected the BIOS, I was booting from tested clean DOS boot disks.

Collapse -

by willcomp In reply to Floppy Drives

Floppy drives provide changeline support that indicates when another diskette has been inserted. When changeline support fails, information from first diskette remains until PC is rebooted. That's what's happening in your case.

Fix is to replace floppy drive.

Dalton

Collapse -

by kewlice33 In reply to Floppy Drives

Test the floppy drive on another computer. If it does the same thing, then you need a floppy drive replacement.

If it works fine on another system, you might have some software issues. If so, you might end up reinstalling Windows.

Collapse -

by Mad Max In reply to Floppy Drives

Of course before you go too far down the road of rip out and replace everything in sight you could check that the Floppy cable is securely seated at both ends and that all pins are engaging ( IE not bent ).

Also check cable for damage or try another known good cable.

MM

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums