Question

Locked

Foxpro, Xp, server shares and me.

By Dumphrey ·
We have an ancient piece of software we use in our call center. Basicly, it is a foxpro database front end, shared out to all the clients over a server share. Randomly, a user one a machine will not be able to do a dealer locate in the database (alwast dealer locate, usually same 2 dealers). The same user will have no trouble doing a lookup on another machine. When the error occures, the message is the the file is marked read-only, or the user does not have suffecient permissions on the lan. And while one or two users may have problems with lookups, another user will have no problems at all on the same effected machine. All machines are identical make/model/and permissions. All had XP pro installed from an MS disk, they are not OEM installs. All share permissions and mappings are the same. Mappings are handled through GP.

At this point, I think I can safely say its not an MS share issue (though it could be) since it is specific in its target (only dealer locates fail).
Does anyone have any experience with Foxpro and feel able to tell me how to check the database for corruption?
Or anyone have any other ideas where to look for a solution to this weird issue?
EDIT:Anyone?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Sharing old databases over the LAN.

by robo_dev In reply to Foxpro, Xp, server shares ...

While database corruption is very possible, I would guess it's just record locking gone wrong.

Here's a link about FoxPro locking errors:
http://support.microsoft.com/kb/93348

Collapse -

Thanks for the reply

by Dumphrey In reply to Sharing old databases ove ...

The error 111 seems to apply to us, but I did not see any resolution, but, it gives me a direction to move in. As far as I know, there should not be any read only files in the database directory, but hay, ya never know.

EDIT: I ran "attrib /s *.* | findstr "^R" > c:\readonly.txt" and got no read only files. So it is either weird ntfs or share permissions, or the database is acting up. None of this ever happened until we upgraded the clients form 2000 to XP. =\

Collapse -

FoxPro, XP profile

by keq In reply to Foxpro, Xp, server shares ...

Have you tried refreshing the Win XP profiles for those users that experience this problem? You can try Deleting the troubled (user's) Win XP profiles then have those users log in creating a fresh profile? Just a thought.

Collapse -

Actually I tried that =(

by Dumphrey In reply to FoxPro, XP profile

And it does not seem to matter. I have come to the conclusion that the database files are corrupt. 1) The errors only occure on 2 accounts. 2) They only occure when running either of 2 scripts. and 3) At this point, it can not be permissions, unless Windows lies to me....
I guess I will have to break down and call the software vendor. We have to pay per incident, since this software is so ancient. ****, they only have 2 techs left that can work with it =\
But thanks for digging up this old question and giving it a go.

Collapse -

Resolved

by Dumphrey In reply to Foxpro, Xp, server shares ...

Well as it turns out, the big mistake was upgrading to XP. I put 2 win2k machines back in place, same permission set up as XP, same users, same hardware, no problems. What ever was changed between XP and 2ksp4 broke consistent compatibility with Foxpro,

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums