Question

Locked

ftp stopped working in the beginning of March 2008

By kreniska ·
I have a scheduled task to run every night to get some files from a ftp site that is outside our company's intranet. It was working fine until the beginning of March. Now I can login OK but get connection refused after I log in when I try to get a Dir listing or transfer a file.
This failure occurs now to multiple ftp sites.
I am using the the ftp.exe that comes with Microsoft Windows XP.
It works when I ftp froma computer inside the company intranet. It only fails when I run ftp from the computers outside the company intranet. These computers have Kerio installed for a VPN connection to our company network. However, it fails even with Kerio disconnected and disabled.
I tried downloading other ftp clients and running them in active mode and they work fine.

Any ideas? Other than switching ftp clients which would be a big pain and expense to do on 100 different computers.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

VPN

by t_w_dragon In reply to ftp stopped working in th ...

You stated the company has a VPN. Chances are the company might have blocked people from accessing it outside the intranet.

If thats the case, just VPN into your company's intranet and access the FTP with the credentials you use if you were physically there.

Collapse -

ftp is to an "external" ftp server

by kreniska In reply to VPN

VPN is usde to access the company's intranet.
But, the ftp site I am trying to reach is outside the company's intranet.
I am running a batch script every 6 hours, so it has to run ftp from a command line in a .bat file.

Collapse -

Tested

by t_w_dragon In reply to ftp is to an "external" f ...

Im assuming you have done this already, but have you tested it outside of your script?

Collapse -

tested - yes

by kreniska In reply to Tested
Collapse -

Why FTP?

by ComputerCookie In reply to ftp stopped working in th ...

If you can access this FTP without using your script, there must be a problem with the script! i.e. you have changed some security setting.

Collapse -

the script has not changed

by kreniska In reply to Why FTP?

I cannot access the FTP site with or without the script. I can login, but I cannnot get a DIR listing or transfer any files. The behavior is the same with the script or interactive.

Back to Desktop Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums