General discussion

Locked

FTP Transfer's

By sbernstecker ·
On a Linux Firewall what module do you use to open Port 20 and Port 21 for FTP transfers bidirectional.

What is the command line you would use to load it, and where would this load command be put so this started everytime the server restarted.And is there a good source on this information (IE:Command Line Switches...)

Thanks for your help.
Steve Bernstecker

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

FTP Transfer's

by Kevin Anderson In reply to FTP Transfer's

An FTP server will be running by default on Linux.

You'll need a userID and password to connect to it. Those can be created with ADDUSER USERNAME, and then giving a password as prompted.

You'll also need to make the user's initial directory the one you want, and make sure they have rights to it. By default, they will default into their own home directory at /home/USERNAME. You can test the server from your desktop by going to

ftp://USERNAME:PASSWORD@xx.xx.xx.xx

Replace xx with the IP address (also username and password). This should work from IE 4 or better, which seems to be the common desktop.

Kev.

Collapse -

FTP Transfer's

by sbernstecker In reply to FTP Transfer's

I have a client that uses a Linux Firewall and needs to connect to my ftp server to transmit and recieve files. I can get him to log on to my server without any problems through DOS FTP commands.When they do a directory it times out by not allowingthem to recieve data back. I believe that Port 20 is blocked which is what is used to transfer data. I believe Port 21 is open which is what allows them to log in to my server. I Might have these ports backwards for there function. This is why I need to know the settings for FTP so we can set it up with them.

Collapse -

FTP Transfer's

by sbernstecker In reply to FTP Transfer's

I have a client that uses a Linux Firewall and needs to connect to my ftp server to transmit and recieve files. I can get him to log on to my server without any problems through DOS FTP commands.When they do a directory it times out by not allowing them to recieve data back. I believe that Port 20 is blocked which is what is used to transfer data. I believe Port 21 is open which is what allows them to log in to my server. I Might have these ports backwards for there function. This is why I needto know the settings for FTP so we can set it up with them.

Collapse -

FTP Transfer's

by jrtietsort In reply to FTP Transfer's

Assuming that you are using the Masq software to do your firewall, you will need to load the ip_masq_ftp module to do this for you. If you are using a relatively recent distribution, then you probably already have the module compiled.

On RedHat:
/sbin/modprobe ip_masq_ftp

You can insert this command into /etc/rc.d/rc.local to have it run when the machine boots. Good luck...

Collapse -

FTP Transfer's

by sbernstecker In reply to FTP Transfer's

Poster rated this answer

Collapse -

FTP Transfer's

by kshum In reply to FTP Transfer's

Try having the client configure their ftp client to use passive transfer. This usually helps when you are trying to ftp through a firewall.

Collapse -

FTP Transfer's

by sbernstecker In reply to FTP Transfer's

The Client is propriatary software published by my company and passive was already tried. I can't get data back through dos ftp ar any way else

Collapse -

FTP Transfer's

by wls In reply to FTP Transfer's

The problem you're facing is that FTP uses one set of ports to communicate user requests, and another set of ports to do the file transfer on.

It works like this:
user -> ftp: "I'd like file XYZ"
ftp -> user: "No problem, connect to port 10328 to get it."
user -> ftp: "Gotcha. Be right back."
user -> firewall "I'd like to open port 10328 please."
firewall -> user "Sorry, that port isn't open for incoming traffic."
user -> ftp: "Something's wrong. I'd like file XYZ please."
ftp -> user: "Sure. Let's try port 30226 this time."
user -> ftp: "Uh, okay..."
user -> firewall "Can I connect to port 30226?"
firewall -> user "Look, I told you, that's not a port open for service to incoming traffic."

...this is what passivemode in FTP solves. It reverses the roles so FTP originates, and the firewall lets it through.

Other than that, you'll need an FTP module for your firewall which will selectively open ports on an as-needed basis.

Collapse -

FTP Transfer's

by sbernstecker In reply to FTP Transfer's

Poster rated this answer

Collapse -

FTP Transfer's

by sbernstecker In reply to FTP Transfer's

This question was closed by the author

Back to Linux Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums