Getting Text file output from Generix/Text Only printer

By warmbeer ·
Trying to get a text file from a print driver through my Citrix connection to my worksite.
I set up a Generic/Text Only printer set to the FILE: Print to File port. When I select print the file name box comes up and it saves the file but all that is in the file is a single character - a small box. I've been using Imageprinter Pro and that works but the sample ran out. Seems like alot to pay for a full program when all I want is to get a text file out.
Am I misunderstanding how the setup above should work? Is buying a program the only way to get this functionality?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you tried different files?

by TobiF In reply to Getting Text file output ...

What if you're dealing with a large image, rather than "text"?

Collapse -

Are you printing to file on the remote machine?

by seanferd In reply to Getting Text file output ...

Or are you trying to print to your machine from the remote?

I would do the former, then copy the file.

If that is what you are doing now, also consider the program from which you are trying to print - anything which might confuse a Windows print driver? Fonts, byte-order,etc.

Collapse -

Access Globally - Print Locally

by warmbeer In reply to Are you printing to file ...

Not sure what an image would tell me? I am trying to get a text version of information on the mainframe. I can print to my local Brother printer and that works fine. But I want to manipulate the data and it is not possible to select it for copying on the Citrix/Rumba/OAS screen. There is a screen print selection that prints an image. Just tried that and get the exact same result.

I tried reinstalling the driver and now I get a row of 3 boxes and another row of maybe 60 boxes, regardless of the page I am printing.

Collapse -

A small square?

by Tony Hopkinson In reply to Getting Text file output ...

That's usually LF in winders.
Suggests to me your file isn't getting through to the driver in the first place.

First things first can you do it without citrix in the equation, ie on your local machine. If so I'd check with the boys who do the citrix configuration, see if they think it should work under your set up.
Citrix is funny beast sometimes.

Collapse -

Not much faith in tech support

by warmbeer In reply to A small square?

Just getting the printing to work to a normal printer was a challenge for them. In the end regular local printing via Citrix only works from some of my machines to some of my printers. If I try just printing a text file to the File port it works ok, accept it also adds a bunch of those boxes here and there and strips out blank lines. About ready to give up and purchase the Imageprinter Pro software, which does actually work ok.

Collapse -

It's been a while since I did anything like this

by Tony Hopkinson In reply to Not much faith in tech su ...

There were some options on the print to file driver, one of them was raw text, another was whether to throw form feeds in there, twiddling with these might get rid of the boxes.
In terms of you only getting a box when doing it remotely there are a lot of config parameters in citrix and they can have a huge impact on how it behaves, got caught out a few times with that, and only your admin guys can deal with it.

Collapse -

thanks any way

by warmbeer In reply to It's been a while since ...

thanks for trying to help. Guess the $30 is worth avoiding the hassle.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums