General discussion

Locked

GNU C Libraries?

By iamsanchez ·
I'm installing xcdroast (cd writing software) on a Red Hat Linux 5.2 system. For reasons I cannot discuss here I cannot upgrade the OS. When I run the 'rpm -ivh filename.rpm' command it's saying that:
libm.so.6 (GLIBC_2.1)is needed by xcdroast
libc.so.6 (GLIBC_2.0)is needed by xcdroast
libc.so.6 (GLIBC_2.1)is needed by xcdroast
I did an 'rpm -q glib' and I'm running glibc-2.0.7-29 version, which is the latest version I was able to find for 5.2.

I have read about upgrading the gnu libraries from source or from binaries and it requires a whole lot to do which sounds kind of scary.

I have the glibc for 6.0. I have the feeling that if I go ahead and run the rpm for it, I'm will be messing up my system. This is an important system and it's working fine right now. I need to add the cd burning facilities though.

Can someone help.

Thank you.
Rafael.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

GNU C Libraries?

by Almighty In reply to GNU C Libraries?

Install at least Red Hat 6.2. That one has GlibC 2.1.3 and that one should take care of you. You say you can't upgrade the OS, but unfortunately I think this is your only way to upgrade the GlibC. The only other possibility that I can think of is toget the 6.2 anyway and see if you can get the GlibC 2.1.3 from there.

Happy Computing !!

Collapse -

GNU C Libraries?

by iamsanchez In reply to GNU C Libraries?
Collapse -

GNU C Libraries?

by iamsanchez In reply to GNU C Libraries?

This question was closed by the author

Back to IT Employment Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums