Question

  • Creator
    Topic
  • #2140537

    Graphics Card not working

    by bitterlight ·

    My graphics card (EVGA Geforce GTX 950) isn’t working, as soon as I boot up my PC the fans spin for a split second and then they stop accelerating and slowly wind down. I’ve tried multiple power supplies and I’ve tried reinserting it but it always does the same thing. It doesn’t help that my motherboard has no HDMI ports so I can’t even display anything without buying an adapter to try and output video through another port.

You are posting a reply to: Graphics Card not working

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    Replies
    • #2414578

      So it powers up fine without the 950?

      by rproffitt ·

      In reply to Graphics Card not working

      That’s not clear in your discussions.

    • #2415571

      graphics card

      by jaceytome ·

      In reply to Graphics Card not working

      Look at the motherboard and the graphics card slots. If the graphics card doesn’t turn on then the issue might be with the slot i.e. the slot might be faulty or damaged. Turn off your computer and take out the graphics card. Insert the graphics card in another slot and check if this makes it work.

    • #2415425

      Graphics

      by richardholder186 ·

      In reply to Graphics Card not working

      I have understood everything, I will try to solve this

Viewing 2 reply threads