Question

Locked

Group policy not setting

By rapell ·
Hello, I am the administrator of a small AD site on a windows 2003 network. Recently the company decided that all user desktop wall paper would be the same with company logo. I decided to try and do this via group policy, but 1 month down the road and none of the machines has taken up the logo wall paper. I have configured a new GPO and blocked inheritance but still nothing. What could be the issue? Thanks

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Make sure it's enabled

by Dedlbug In reply to Group policy not setting

Just to get on the same page, do you already have a policy that is enabled and working on the LAN currently? If you configured a new GPO, you will have to enable it and make sure your Domain is linked to that GPO. It's not best practice to edit the Default Domain policy, but you can always try that.

The setting that you have to change is in User Configuration - Administrative Templetes - Desktop - Active Desktop - Active Desktop Wallpaper. You have to enable this policy and you can enter a path for an existing image to use. I'm not sure, but I think there is a work around for users in the domain to be able to bypass this setting, but it will prevent the "Right-click on Desktop/Properties" that users commonly do to change the wallpaper.

Collapse -

done that

by rapell In reply to Make sure it's enabled

but still the same thing, the GPO linked and enabled. Is there any command I can use on a client and it applied the wall paper? apart from gpupdate /force?

Collapse -

Review The mix

by jclalama In reply to done that

In order to GPO relationed with wallpaper function check the next policies aldo are enabled:
User Configuration
Administrative Templates
Desktop/Active Desktop
Wallpaper Name: Your wallpaper
Enable Active Desktop: Allows HTML
and JPEG Wallpaper


Otionasl are:
Prohibit adding items Enabled
Prohibit changes Enabled
Prohibit closing items Enabled
Prohibit deleting items Enabled
Prohibit editing items Enabled


After that, try with the Group Policy Result in order to chech your entire policy.

Good Luck Friend

Collapse -

Items to consider

by SmilingSheep In reply to Group policy not setting

1. Make sure the new policy and all policies are set to merge. I've seen some weird non-results with the processing set to overwrite.

2. Use GPMC to run a resultant set of policy on one use on a particular machine to make sure the policy is effectively applying.

3. Put the background image locally on the workstations and path relatively to it. Don't try to load the background image from a file server/share.

4. Look for policy errors in the workstations after a reboot or gpupdate /force. Sometimes the part of the GPO that's failing to apply will generate a log entry.

Collapse -

Why?

by john.light In reply to Group policy not setting

Why did you block inheritance?

to help debug.. use GPMC to get a RSOP on a computer. Also turn debug on and look at the more detail login c:\window\debug\UserMode\userenv.log
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"UserEnvDebugLevel"=dword:00010002

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Diagnostics]
"FdeployDebugLevel"=dword:0x0f

Collapse -

Location

by retro77 In reply to Group policy not setting

-Where do you the GPO applied?

-Is this a machine based GPO or a User based GPO?

-Write a script to copy that wall paper to the C:\Windows directory on all of the workstations. Have the GPO point to that location for the wallpaper

-Dont have a space in the name of the wallpaper.

Collapse -

User based

by rapell In reply to Location

GPO. I guess I got the problem(if it is actually the problem). Maybe you pros out there may investigate and comment, please. thanks.
Now, I had bundled up all the users in my OU into a security group, and also all the computers into another security group when the GPO was not applying. So i decided to remove myself from the security group, and add my username to the OU as is. The did gpupdate /force and it worked almost immediately on my desktop. I proceeded to remove all users from the security group as well and the next day when they logged into their systems, it also worked. I wonder why?? After all, the security group was in the OU! Thanks for all contributions.

Collapse -

GPO Security

by SmilingSheep In reply to User based

Its not apparent if you're using GPMC, but you'll want to look at the security settings, specifically who has read & apply policy settings rights. Although the security group was in the same OU as the policy, the security must be set properly for the GPO to apply to a group (even if the group is Authenticated Users).

Collapse -

what do you mean "properly"

by rapell In reply to GPO Security

what do you mean? much as it has worked, I would have liked to not disrupt my settings just to make a desktop look like a logo, so many settings have been lost. Please elaborate and give workaround to doing this and it propagates to security group. Thanks

Collapse -

well OUs don't have to be security groups

by CG IT In reply to what do you mean "properl ...

OUs are containers. They don't necessarily have to be security groups. you want security groups when you need to restrict access [or grant access].

if you want to control user desktop experience, you don't need OUs created in a security group to do that.

you could create and if that OU is nested inside another OU, the child [OU you created] inherits the parents plus the GPO you applied to the child. The resulting set might conflict [parent/child] so the parent applies [which means your GPO with the wall paper doesn't get applied].

could be a lot of things.........

tough to say without seeing a diagram of the OU structure and the GPOs assigned to OUs.

Back to Software Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums