General discussion

Locked

Hard Drive problems

By rmhughes0711 ·
I have attached a Maxtor 80Gb drive to a PC. When I boot up, the BIOS recognizes it and when XP loads, I can see the drive when I click on My Computer. When I click on the drive, however, I get a message that says "incorrect parameter" and I am not able to go further. This is not the boot drive, rather, it is an extra data drive.

What does this message indicate? Is there a way around it?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to Hard Drive problems

sounds like you need to use Disk Manager to write a signature to the drive, then create a partition on it and format it. Look for how under Help in XP or here are the general instructions:
right-click My Computer, pick Manage.
Pick Disk Management, then find your maxtor. right-click on the drive description, pick Write Signature. then follow the prompts to create a partition and format it. you can safely take all the defaults probably.

Collapse -

by dave In reply to Hard Drive problems

How old is the motherboard? Does it recognize the drive as an 80gB? If not, then disable (NONE) the drive in the BIOS and let XP identify it. If you cannot disable it (or that doesn't work) set the BIOS to a minimum capacity drive.
At any rate, you don't want to use Maxtors drive overlay program since XP has one built in. You can use fdisk /MBR to remove the overlay or run Maxtor's Ontrack to remove it.

Collapse -

by jon In reply to Hard Drive problems

Perhaps it's a security issue? If you attempt to switch the mouse focus to the drive do you get the error? Is it only when you try to double-click on it to explore it?

Go into Control Panel --> Administrative Tools --> Computer Management --> Disk Management

If the drive is listed, make sure it's proper, whether you have to import it, re-activate it, etc...it will depend.

If you can do that, perhaps that will fix the problem.

On the other hand, perhaps all you need to do is right click the drive, click on the security tab, then replace the owner of the drive and set it to reset all sub-folders.

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums