General discussion

Locked

Hard Drives "not installed" in bios

By enchantrix ·
Hi there,

I am currently trying to fix a machine that has been broken for a long time. What happens is when the machine is switched on it makes it as far as the Windows XP Professional loading screen and then gets stuck there and does no progress any further.

I put the Windows XP CD in it and tried to boot it from CD. I thought if I could get to the windows recovery console I would be able to do chkdsk to try fix it however before I could even get that far I got a message saying that it couldnt find any hard disk drives and needed to exit.

I then had a look in the bios and saw that Primarey IDE drive was listed as "not installed", the primary IDE slave listed the Sony DVD drive, secondary IDE drive "not installed" and secondary IDE slave also "not installed".

On closer inspection inside the case there are two Maxtor DiamondMAX Plus 9 160Gb harddrives. Also inside the case is a 3 1/2" floppy drive someone has connected up. inside the floppy drive there was a disk which I have been told has the RAID drivers for these hard drives on but the metal bit on the disk seems to have been bent a bit and the window mechanism on the floppy itself is now jammed open.

So any idea how I can make a start at getting these hard drives set up and configured? I was thinking I might need to use a working PC to download some type of setup file and burn it on a CD and pop it in the broken machine?

Any help, advice very very much appreciated. If any further information is needed just ask.

Thanks

Rosie Hamilton

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Murray Brydon In reply to Hard Drives "not installe ...

Really need more info on the type of motherboard, as it could be one with a built in RAID controller, so you would be able to see (by looking inside) that of the two IDE channels only the DVD drive is connected to it and the HD's will be connected to a similar IDE connector on the motherboard.
If this is the case then it is supposed to say that nothing is detected on the channels as that is the case, but there should be another utility either in the BIOS setup, or by pressing another key that will get you into the RAID settings.
First thing I would try changing the IDE cables and check that you are using the correct type (i.e. not using a 40 cable when you should be using an 80 as this hangs XP/2K at startup all the time)

Collapse -

by enchantrix In reply to Hard Drives "not installe ...

I have been told the motherboard is MSI K8T Neo-FIS2R SKT 754 K8T800 8x AGP GB LAN 1394,S-ATA RAID 6CH Sound.

Closer inspection inside the case I can see both hard drives have 2 sets of wires going into them, one i'm assuming is power the other cable runs straight from the hard drive to the mother board it looks about the same size/shape as a USB cable.

The DVD drive goes straight onto the mother board but its connector is a lot larger than the ones from the hard drives.

I know for certain the IDE cables are of the correct type as the machine was working fine for a long time before this problem started and (I am assuming) if the cables were of the wrong type (40 instead of 80) then it wouldnt have worked in the first place.

Collapse -

by HAL 9000 Moderator In reply to Hard Drives "not installe ...

Well the HDD sound as if they are SATA Drives and are very likely setup as a RAID array. The Floppy that is stuck in the drive is most likely the RAID Software to use when Windows XP is installed to install the RAID drivers.

SO first thing would be to remove the Floppy drive replace it and then with another computer download the RAID Drivers from the M'Board makers Web Site and copy them to a floppy. It sounds as if the RAID has somehow either been deleted or a drive has failed but being on the SATA controller the most likely thing is that the driver for the SATA controller has been removed or become corrupted.

You'll need to get in contact with the owner and see if the RAID was set to 0 or 1 if you are to have any hope of recovering their data but no matter how it was setup you will not get any notification of the SATA drives in the BIOS as it only picks up the IDE type and when you try to boot from the Windows XP CD you are failing to press the F6 key to install the RAID drivers so effectively the HDD's are not present.

If the SATA leads are of the type that go through a right angle bend at the back of the HDD make sure that they are fully inserted into the drives as these can and do pull part way out, if they are the straight ones this isn't a problem.

Col

Collapse -

by HAL 9000 Moderator In reply to

These are SATA HDD's and have to be connected to the RAID controller for Technical Data on these Drives see

http://www.maxtor.com/_files/maxtor/en_us/documentation/quick_specs/quickspecs_sata.pdf

Collapse -

by CptOmlly In reply to Hard Drives "not installe ...

Are you sure that these are IDE drives? The description in your comment sounds more like Serial ATA. Are you sure that the hard drives ever showed up in the IDE device list?

My bet is that they didn't, but you never noticed until the machine was broken. However, most BIOS show the devices connected to SATA somewhere during the boot. Watch the boot process and look for a list of SATA devices. If you don't see them listed, you probably have a problem with the motherboard.

Collapse -

by enchantrix In reply to Hard Drives "not installe ...

Well im sure now that they are SATA drives as the disk inside the floppy drive inside the machine has written on it G72-VASA020 VIA SATA RAID Driver for VT6420/VT8237

I have been to Maxtors website now and downloaded an iso of bootable CD image file to test the hard drives.

The drives are listed as
PDC20373 Primary Master Maxtor 6Y160M0

and
PDC20373 Secondary Master Maxtor 6Y160M0

The Primary drive passes all the tests fine. The Secondary drive however says that partition information is absent (the primary drive has partition information) and when doing an advanced read / write test on the secondary drive it says that "this drive is failing. If you do not have a recent back-up of the data please do so now if possible." and then goes on about writing down some diagnostic code to contact Maxtor for return merchandise authorisation.

So does this mean that this RAID set up needs one of the hard drives replacing? Does it also need new drivers from somewhere?

Collapse -

by willpd13 In reply to Hard Drives "not installe ...

Rosie,

I am afraid to say that it sounds like the only way you will get this PC running again is to download the SATA RAID drivers and format it. If you cannot get it to boot and one of the two hard drives you have in a RAID configuration has failed then you will probably have lost the data on both drives as the RAID cannot function with part of the partition missing. As you only have 2 hard disks it sounds like a striped partition which does not have any kind of redundancy if one drive fails the whole lot goes. If you want to try and scandisk the drive you can boot from the windows XP disk and press F6 (I think thats right anyway) to load third party drivers such as the RAID drivers so you can access the drives attached to the RAID controler.

Hope this helps

Regards,

Paul Williams

Collapse -

by psjjl In reply to Hard Drives "not installe ...

Check if the IDE cable is ok. If so, u may update your motherboard bios so that the big drive will able be detected. Configure this by only install one big drive at Primary master drive & install Sony DVD drive as Secondary master drive. Continue only once your motherboard is able to detect the first big drive.

Collapse -

by enchantrix In reply to

Poster rated this answer.

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums