General discussion

Locked

HD Master NTFS, Slave FAT32. Possible?

By stefanrp97 ·
I have a NTFS hard drive as a master from my computer. I took the hard drive out of my old computer and placed it within my new one. The old drive is formatted as FAT32. Is there any way to get the two to work in the same computer? Appreciate any help. Thx.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Megkilla In reply to HD Master NTFS, Slave FAT ...

Hi,

In a normal case, everything will work finely. But maybe you'll have problem with the FAT32, but it's possible to change the FAT32 to NTFS by using this command :

convert *drive_letter*: /fs:ntfs

But be carefull, if everything works fine, you don't need to do that. This command will convert your filesystem without destroying all your datas, but make a backup if you can.

Hope it'll help.

Collapse -

by fungus-among-us In reply to HD Master NTFS, Slave FAT ...

Sure you can. You can even have two different file systems on the same hard drive if you want to (if your drive is partitioned). The only concern I have is the fact that both hard drives, individually have their partitions (assuming one partition per drive) set as the ACTIVE partition.

Collapse -

by BobTheITBuilder In reply to HD Master NTFS, Slave FAT ...

NTFS is backwards compatable with FAT32 and your OS booted up on NTFS should have no problem seeing a HDD formatted with FAT32. However the oposite is not true. Therefor I think that because you have taken the FAT32 HDD out of another PC that HDD would have the jumper pin set to Master and this would cause problems if both HDDs are on the same IDE channel. Check your jumper pin/IDE Channel.

Collapse -

by mjd420nova In reply to HD Master NTFS, Slave FAT ...

Yes, it should work fine. I'm using it on three out of four systems. They are from older machines and wer placed as slaves in the new units when they were built. No trouble.

Collapse -

by stefanrp97 In reply to HD Master NTFS, Slave FAT ...

I took the jumper off the hard drive because that is what the diagram showed as a slave drive. Windows XP still doesnt even register the drive in My Computer, but it shows up in drive management.

Collapse -

by TheChas In reply to HD Master NTFS, Slave FAT ...

A couple of things to check:

Make sure that the jumpers are set correctly on the NTFS drive. Many drives have different jumper settings for Master with Slave present versus a single drive.

I can't recall ever seeing a drive with NO jumpers required for being a slave.

If your IDE cable has labels on it for Master and Slave, it may be a cable select style cable and you should set both drives to cable select and plug the cable into the appropriate drive.

Enter BIOS setup and make sure that the second drive is set to Auto Detect, or displays the correct details for the second drive.

If the BIOS is set to none, it cannot detect the new drive.

Finally, I have run into more than one instance where 2 different brand drives do not work properly when connected to the same IDE cable.
Try connecting the second drive to the same cable as your CD-ROM drive.

Chas

Collapse -

by HAL 9000 Moderator In reply to HD Master NTFS, Slave FAT ...

Well if it's showing up in drive management all you need do is right click on the drive and mount it.

But as Chas has said previously I can't think of any HDD where the jumper is removed to be a slave every drive that I've ever used the slave has to be shorting 2 pins to make it usable. I would tend to go with the Cable Select or CS option here to make the unit usable as I think that while the Disk Manager can see the drive it can not mount it because of incorrect addressing.

Col

Collapse -

by Deadly Ernest In reply to HD Master NTFS, Slave FAT ...

The only things that I can add to what has already be said is:

1. Usually no jumpers means Cable Select not Slave, in some older drives no jumpers means Master.

2. What size and how old is the drive, some of the older drives do not work properly when plugged into an 80 pin IDE cable as they were designed for a 40 pin cable. And the modern drives don't work on the 40 pin cables as they're designed for the 80 pin cables. If this is the cause of the problem, then you will need to put the old drive onto the secondary IDE channel with a 40 pin cable.

best to try putting on drive on each IDE channel and see what you get. Also check how they are reading in the BIOS as well.

Collapse -

by stefanrp97 In reply to HD Master NTFS, Slave FAT ...

A friend of mine helped me out and I had to change the FAT32 drive from basic to dynamic in order to assign a drive letter. :% I had seen that option before when I was looking around in drive management, but was unsure of what it did and did not want to risk losing the drive information. Thanks to all who helped out. Problem is solved.

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums