Question

Locked

Help - How to delete a registry key?(not simple)

By maruxiao ·
The situation is, I was installing Office 2010 on my Vista, but if I choose to do a full install it just won't complete and rollback halfway(tried to only install Access and it worked. But I need other components as well).
Error log shows error 1603, and when I use Process Monitor I can see some "ACCESS DENIED" when accessing registry. It pointed to HKCR\.odt and HKCR\.ods(created by OpenOffice I think). I'm sure that these keys caused installation failure according to error 1603's definition. so I used regedit to look in it. At first I got Access Denied too, and I set to own the key and Full Access to everyone. BUT I still can't delete it. So I booted to PE and deleted those keys, it seems to be deleted and I unloaded my registry after deleted it. When I reboot to my Vista, these keys are still there. I could delete .ods and did it, but .odt is still there and cannot be deleted. The weirdest thing is that when I try to access subkeys such as shellex, I got an error: System cannot find the file specified.(or something like it, I'm using Chinese version now.)
Now I'm stuck. I dunno what to do to delete that key. I think most tools are for cleaning registry and not actually repairing it. Please help me, how to get rid of that registry key?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How about...

by TobiF In reply to Help - How to delete a re ...

I googled a couple of minutes, to see what this error is about.

I don't think MS office will bother at all about if some open-office file types are defined in the system.

However, the fact that these keys are recreated indicates that something from OpenOffice is automatically starting in the background when you boot your machine.
Have a look in Task Manager (check the list of processes). It then might be possible that this OpenOffice process locks some kind of resource that MS Office needs to update. (If you find a resident OpenOffice process, try killing it in same task manager)

You can also try to get an inventory of what is automatically started on your system, and how. I think sysinternals autoruns could be of help in this.

If you don't find anything autostarted from Open Office, then it's time to hunt for rootkits and malware, but I really that's not the case.

And, as food for thought, while quickly browsing the top results i found via Google, I noted this checklist, which might also help in your quest: http://www.windowsvalley.com/fix-error-1603-fatal-error-during-installation/

EditAdd: Have a quick read of this kb from Microsoft: http://support.microsoft.com/kb/834484

Collapse -

but msiexec tried to do sth

by maruxiao In reply to How about...

msiexec tried to do sth on that key, and returned ACCESS DENIED. I dunno why but it just did it. Also 2 font files are triggered ACCESS DENIED too, maybe that's the point? Gonna verify it tomorrow, it's 22:00 here now.

I have sysinternals suite and checked twice that no process running and autostarting are related to OOo. Only a context menu handler and 4 shell extensions. In fact I don't have a uninstaller of OOo either, not in uninstall list.

Collapse -

Aha

by TobiF In reply to but msiexec tried to do s ...

I guess the context menu controller recreates the OO file types (and may be locking on to these entries).

I'd try to temporarily disable the menu handler and shell extensions while installing.

Collapse -

no luck

by maruxiao In reply to Aha

Still can't delete that key. Says Error while deleting key. subkeys are still " cannot find the file specified".

Collapse -

Hmmm

by Tony Hopkinson In reply to Help - How to delete a re ...

Sounds like you've at an msi problem to me.
MS have a now deprecated installer clean up application ( called Windows Install Clean Up), invented for office as they stuffed up the registry leaving windows installer in a loop.

You could also try RevoUninstaller.

Both will find broken installations, same product more than once in Program features, or won't go aways or says it isn't there but it is.

Note be careful, RevoUninstaller particularky isnlt fro teh faint hearted, I's try download the MS one first if I were you.

Try and wipe all evidence of an office install ever occuring.

PS 1603 from windows installer is basically something went wrong that we couldn't deal with. Covers everything from not enough disk space to fail code from something else that it had to run. It's near useless unless you can step through the installer.

Collapse -

Tried to uninstall

by maruxiao In reply to Hmmm

I used 3 vbs to remove Office11 12 and 14. They are from MSKB:
http://support.microsoft.com/kb/290301
and tried to install. No luck.

Tried to manually remove Office12 using another KB, still no luck.

Collapse -

TODO list

by maruxiao In reply to Help - How to delete a re ...

So I'm gonna check these things tomorrow:

1.reinstall widows installer(Does it matter?)
2.check those fonts
3.already disabled extensions or handlers, try reboot and delete keys tomorrow

In fact I only need Access for learning about databases, but it's pain to open ppt in oo impress because things are messed and many other problems...

Back to Software Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums