General discussion


help me to get login prompt on telnet ma

By chidimark ·
i have a linux machine ,i connect to linux from other (nt domain) machine using telnet
ie. ip address of my lynux machine.from ntdomain a connection is established, the connection window displays
the remote host's login screen but here it doesn't prompts me for the login and passowrd but blinks after displaying
"Red hat linux release 6.0(Hedwig)
Kernel 2.2.5-15 on an i686
_ " after this it simply blinks instead of prompting me a login screen and password.
i found that these two machines do communicate with each other by ping from both the ends and it was giving me reply.
i checked cabling, configuration from nt and found it to be ok. do i need to configure the linux machine if yes what configurations please help me out...
i m in a great trouble kindly respond me i m in urgent need of this solution.


This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

help me to get login prompt on telnet ma

by Shanghai Sam In reply to help me to get login prom ...

Telnetd accepts the connection initially. It displays the issue file and then calls /bin/login to show the login prompt and authenticate a user.

The problem you are having appears to be the /bin/login process is not running. When you do a telnetto the box, try doing a ps -e f | more and searching for the telnetd process. The telnetd process should have a login process as a child.

The /etc/inet.d file should have a line similar to:

telnet stream tcp nowait telnetd.telnetd /usr/sbin/tcpd /usr/sbin/in.telnetd

You might check there. Note that whenever you modify the file, do a kill -HUP of the inetd process to reload the options.

Hopefully that will get you looking in the right direction.

Brainbench'Most Valuable Professional' for Network Concepts
Brainbench 'Most Valuable Professional' for Linux Admin

Collapse -

help me to get login prompt on telnet ma

by paulo.sedrez In reply to help me to get login prom ...

This is most likelly a reverse name resolution problem. As a quick fix, put the IP and name of your servers in the /etc/hosts file. Also check that the file is used prior to DNS in name resolution (if you have /etc/nsswitch.conf, check the line for"host", that "files" comes prior to "dns"; if you have /etc/host.conf; check the line for "order", that "hosts" comes prior to "bind").


Back to Linux Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums