Question

Locked

HELP!!, Usb Flash Memory Partition Problems

By octaviolandolfi ·
I just receive a u-stix 512mb flash drive, it brought some security and partition program, I decide to divide my F.D. into 2 halfs 256 each, one with password, the other normally. The problem is that now i can only access the unprotected part, the other one appear as a disk drive, and when i hit it it says insert disk, and the little program?, no where to be found. Please i really need help to undo these, or a program to merge the two partitions, help!!!

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Firstly I'm not sure that you can partition a USB Drive

by HAL 9000 Moderator In reply to HELP!!, Usb Flash Memory ...

But as you already have a mess on your hands go into Computer Management and delete the partition that's not working and then with something like Partition Magic or System Commander try resizing the initial 256 MEG Partition.

I've never tried to partition a USB Thumb Drive as they are RAM not a physical Drive only a Virtual Drive so I'm not sure if it's possible. As I've never tried formatting one I would not suggest removing both partitions and trying to perform a format of the USB Device from Computer Management as it will no doubt attempt to make it a NTFS partition which doesn't work with USB Thumb Drives as they are all FAT32 Partitions.

Col

Collapse -

Reply to Hal

by octaviolandolfi In reply to Firstly I'm not sure that ...

That program that the USB brought was the one that did it. The partition was suposed to have a password, but it became like a cd drive or something. and i can?t delete it from computer manager...

Collapse -

Well since the software came with the USB Thumb Drive

by HAL 9000 Moderator In reply to Reply to Hal

Take it back and either ask for an exchange/refund or get them to setup the thing.

If a company is selling something it has to be of Saleable Quality or they are unable to sell it in the country and must offer support for the item in some form generally replacement/refund.

Though in this case it's possible that you need to mount the second partition through the software that was installed something like Virtual CD. That may be your answer though without knowing the software involved it's a bit hard to say.

Col

Collapse -

2nd Reply

by octaviolandolfi In reply to Well since the software c ...

Well, i?ve try to look for it on the internet, but apparently there is this company that makes them, and then sells them to other companys, and then they sell them with their brand. I think that i just buy another one. because it was a present for a friend and i wont see her until january, mean while i?ll keep triying, because it must be a way to solve this thing, in computer related stuff there is always a way.

Collapse -

(Late Answer)What brand of "drive"

by mats In reply to 2nd Reply

Is it a "U3" compatible drive ??
((what brand?))
I can't guarantie that my explanation is correct for Your drive since it is limited to two "Cruiser microDrives" that are the only USB-drives I've had that are "U3 compatible".
My experience of "U3" is the following:
= = = = = =
The drive is "partitioned" in two partitions.
The "first" partition is formated with CDFS (Yes that's right the same as a CD)
The CDFS formated partition is verry small (ca.6MB) and Write Protected, it is not supposed to be used as a storage area.
The "CD-partition" only contains "administration programs" that are started with an "Autostart.inf" file.
The second partition is formated with FAT32
The FAT32-partitions size is "the rest of the drive"((when the first partition is deducted from the total drive capacity))
The FAT32-partition contains a number of preinstalled "utilityPrograms" supposed to make the drive more "usefull".
The FAT32-partition is allso the one that is supposed to be used as "storage area".
=== === === ===
Now to my guess of Your problem and its remedy.
I believe that You have "unintentionally" password protected the "second partition". That will give the symptoms You describe.
The remedy to that is to look in the "first partition" for an application (exe-file) that is supposed to "start" the "second partition". In the case of "SanDiscs Cruiser" this program is called "LaunchU3.exe".
If You start this program it will "prompt" ((ask)) You for the password. And if You fill in the correct password "the second partition" will be made available....
Hope this helps You (or someOne else)

Collapse -

fix for usb partition or "please insert disk" errors

by boredpcola In reply to HELP!!, Usb Flash Memory ...

Hi guys,
I recently had an issue with my pny attache 1gb usb flash drive. I was receiving a message "please insert disk" when tring to access my flash drive. Seems that quite a few others have had or are having the same issue so I am offering advice on the fix which worked for me.
First you need to download the following program.
http://hddguru.com/content/en/softwa...l-Format-Tool/
once installed open the program and plug in your usb device, it should show up on the list, if not try closing the program and reopening to refresh it.
It is very important that you select only the drive you wish to erase, so select your drive and procede. Once the operation is complete safely remove your flash drive and reinsert. Then open "my computer" or right click START to explore to your drive. Highlight your drive and right click it for a dropdown of options, select format and choose your file system and volume name. DO NOT use quick format. Once this process finishes you should be able to access your drive once again and begin rejoicing.
I hope this helps you guys out, took me about 3 hours to find a fix that actually worked. Shoot me an E-mail if this worked for you or you need help with any of the details.
Boredpcola@aol.com

Back to Hardware Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums